[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problem mit Packages (Depends)



Hi,

Oliver Neumann [New Identity AG] wrote:
> ich hätte zwei Fragen die von der FAQ
> (http://www.de.debian.org/debian-user-german-FAQ/) leider nicht beantwortet
> werden (denke ich :-) ).

UND WARUM ZU GEIER SCHREIBST DU DIE _DREI_MAL ?

> Wir haben uns eigene Packages gebaut (unter Debian 3.0RC1) und geben in
> unseren control-files bspw. folgendes als dependencies an :
> 
>   -x-x-x- control -x-x-x-
>   Depends: apache (>=1.3.26 | <=1.3.28)
>   -x-x-x- control -x-x-x-
> 
> Leider ist es nun so, dass die Standard-Pakete unter Debian
> apache-1.3.26-woody oder änhlich heißen, dies wird dann aber leider nicht
> mehr erkannt (also apt-get "denkt", dass apache-1.3.26-woody nicht das
> Depends-Requirement erfüllt. Was können wir hier tun, damit das
> funktioniert?

äh, doch. Das Paketsystem erkennt das.

$ dpkg --compare-versions 1.3.26 lt 1.3.26-woody && echo "jo"
jo

$ dpkg --compare-versions 1.3.26 lt 1.3.26woody && echo "jo"
jo

Was geht denn da bei Dir nicht?

Grüße/Regards,

René
-- 
 .''`.  René Engelhard -- Debian GNU/Linux Developer
 : :' : http://www.debian.org | http://people.debian.org/~rene/
 `. `'  rene@debian.org | GnuPG-Key ID: 248AEB73
   `-   Fingerprint: 41FA F208 28D4 7CA5 19BB  7AD9 F859 90B0 248A EB73
      

Attachment: pgpGMfk5X9xNG.pgp
Description: PGP signature


Reply to: