[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: alsa-Problem - Zwischenbericht und midi



Am / On Wed, 20 Nov 2002 11:51:12 +0100
schrieb Frank Barknecht <barknech@ph-cip.uni-koeln.de>:

> Tja, da gibt es jetzt wieder eine Änderung bei den Alsa-Modules, gilt
> ab rc5: 
> 
> Die Module-*Optionen* haben ihren Präfix "snd_" verloren. 
> 
> Die Optionen sind ja alle für Sound-Module, da haben sich die
> Alsa-Entwickler gedacht: Wir sparen ein wenig Tipparbeit. Die
> Fehlermeldung, die du kriegst, weist auch darauf hin, dass
> "parm_snd_device_mode" nicht valide ist. 
> 
> Statt "snd_device_mode=0660" muss es jetzt heißen: "device_mode=0660"
> usw. für die anderen Optionen auch. Aber nicht die Modulenamen selber
> ändern, die behalten ihr "snd-"

Lieber Frank,

ich habe das snd in den Parameterangaben entfernt und bei der
Gelegenheit auch gleich noch eine dummy-Karte eingefügt, allerdings ohne
Erfolg. Der sblive-Treiber startet nur wenn ich ihm keine Optionen mit
auf den Weg gebe. Die entsprechende Zeile in der Datei
/etc/alsa/modutils/0.9 lautete:

options snd-emu10k1 index=0 id=CARD_0 dac_frame_size=128
adc_frame_size=64

Es funktioniert aber nur ohne die Angaben zu dac_freme_size und
adc_frame_size. Habe allerdings keine Ahnung was für sizes ich dann
habe.

Zudem bin ich immer noch ratlos was midi angeht (das war mal der Grund
für den Wechsel vom oss-kernel- zum alsa-Treiber): 
Ich habe mir ausden awe-utils das Programm sfxload compiliert und die
eine sf2-Bank von der SBLive-CD in die Karte geladen. 
Von meinen Versuchen mit brahms will ich hier gar nicht erst anfangen,
aber auch mit pmidi-0.9 läßt sich jedoch keinerlei midi abspielen. Der
Befehl
 pmidi -p 65:0 bach.mid
führt zwar dazu, dass kein neuer Prompt und keine Fehlermeldung
erscheint, es ist aber nicht zu hören. Dafür zeigt aconnect -o bei jedem
Versuch einen neuen client mit einem port an.

Any hints?

Die Dokumentationslage ist ja was alsa 0.9 angeht auch eher mager.

Klaumi

-- 
Klaus-M. Klingsporn            
klaumikli@tiscali.de
http://www.klaumikli.de



Reply to: