[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Re : [etch] Blocage au demarrage, initramfs, PERC5, driver



Bonjour,

C'est pas recommandé pour de la production, mais tu peux essayer
(pour voir) de mettre un autre noyau. Par exemple un 2.6.22 des backports :
deb http://www.backports.org/debian etch-backports main contrib non-free
#deb-src http://www.backports.org/debian etch-backports main contrib non-free

Pour le initrd, je crois qu'il y a rien besoin de rajouter avec les PERC

Sinon vérifie bien toutes les connectiques. ça ressemble quand même plus
a un problème matos/connectique ...

Guy


djibril ousmanou a écrit :
Salut,
Bon je vais re-expliquer ce que j'ai fait.
Mon serveur est un power edge 850 avec deux disques SCSI d'environ 300Go.
Mon serveur de stockage est un Power MD1000 avec 4 disques de 750 Go.

1 -  Démontage du rack (de mon power edge)
2 - Rajout de la carte (pour relier au serveur de stockage)
3-  Branchements effectués
4- Allumage de la baie
5- Allumage de mon power edge
6- A un moment donné, ctrl - R to run configuration utility
7- On arrive sur une  interface graphique  PERC 5/E Adaptater Bios configuration utility
8- F2 plus je ne sais plus et je configurer en raid5
9-  Tout est Ok,  la configuration est en cours, je peux déjà utiliser les disques
10- J'installe debian etch via le réseau (debian-40r3-i386-netinst)
11- Je met le CD d'installation et sort de la fenêtre de configuration
12- Je fais tout le tralala d'installation sans souci.
Au niveau des partitions, je choisi partition manuel. Les deux disques SCSI du power edge + celui de la baie sont détectés correctement.
Sur le disque 1, je crée 3 partitions (la swap à 1 Go, la / ext3 à 12 Go je crois et /sauvegarde1 ext3 avec le reste d'espace disque.
Sur le disque 2, je crée une partition prenant tout l'espace disque /sauvegarde2 ext3 Sur le disque 3 de la baie (j'ai donc 2,2 To de dispo, 3 x 750 Go), je crée une partition de 2 To 13- Je termine l'installation de Debian
14- Tout est ok, j'obtiens bien une interface Debian, je vois correctement mes disque via df -Th, etc
15- je termine mes configuration réseau, perl, ssh, etc. 16- j'ouvre le fichier /etc/apt/source.list et enlève les sources du CD histoire de pas avoir à utiliser le CD pour mes update ou recherche de packages.. 17 - je fais un apt-get update et apt-get upgrade
18- Tout à l'air OK, je décide de redémarrer le serveur et paff, mes amis (messages d'erreurs) débarquent lol.
19- je constate donc que c'est aleatoire après plusieurs reboot.
20- Je décide donc de faire une copie de mon initrd.img-2.6.18-6-686 21- Je tente de faire des rajouts de modules dans /etc/initramfs-tools/modules en mettant megaraid, megaraid_sas, megaraid_mm, megaraid_mbox, ata_piix, etc puis j'effectué la commande update-initramfs -v -u
et rien à faire, ça ne démarré même plus.
22- Pour le faire fonctionner, obligé d'éteindre la baie. et redémarrer le serveur. Puis Ctrl-D car ça plante vu qu'il ne trouvait pas la partition de la baie 23- A ce jour, du moins hier, j'ai donc remis /etc/initramfs-tools/modules comme il était avant c'est à dire vide. j'ai relancé la commande update-initramfs -k 2.6.18-6-686 -u -v (en spécifiant bien -k 2.6.18-6-686 ce que je ne faisait pas avant), puis j'ai rallumé la baie et redémarré mon serveur power edge.
24- et là ça fonctionne pas de soucis. Ensuite shutdowh -h now puis j'allume, pas de soucis
25- Troisième shutdowh -h now puis j'allume => pafff, plantage.
26- reboot => plantage, 27- reboot => plantage, 28- reboot + j'eteins et rallume la baie en même temps => plantage, 29- baie eteins et reboot, etc etc connexion au serveur 30- fichier /proc/modules
cat /proc/modules  | grep megara
megaraid_sas 24428 0 - Live 0xf8842000
scsi_mod 124168 4 sd_mod,megaraid_sas,aic7xxx,scsi_transport_spi, Live 0xf889c000

cat /boot/config-2.6.18-6-686 | grep -i megaraid
CONFIG_MEGARAID_NEWGEN=y
CONFIG_MEGARAID_MM=m
CONFIG_MEGARAID_MAILBOX=m
CONFIG_MEGARAID_LEGACY=m
CONFIG_MEGARAID_SAS=m

 et sur un autre de mes serveurs Debian
cat /proc/modules  | grep megara
megaraid_mbox 30192 4 - Live 0xf8849000
scsi_mod 124936 3 sg,sd_mod,megaraid_mbox, Live 0xf889f000
megaraid_mm 11360 1 megaraid_mbox, Live 0xf8824000


Voilà, je ne sais plus quoi faire

Merci pour vos réponses
----- Message d'origine ----
De : Edi Stojicevic <estojicevic@debianworld.org>
À : debian-user-french@lists.debian.org
Envoyé le : Vendredi, 28 Mars 2008, 11h12mn 53s
Objet : Re: [etch] Blocage au demarrage, initramfs, PERC5, driver

* Edi Stojicevic <estojicevic@debianworld.org> [2008-03-28 10:06:54 +0000] wrote :

* Gilles Mocellin <gilles.mocellin@free.fr> [2008-03-27 21:36:33 +0100] wrote :

Si c'est bien du raid hardware, le système ne devrait pas te parler de sda,
sdb mais les nommer en tant que disques raid (mdX ?).

Ben justement pas.

Mais Bonsoir quand même.

Les cartes RAID materiel font voir un disque virtuel, résultat du RAID au système.
Ce disque virtuel est généralement vu comme un disque SCSI.
Chez HP, sur les Proliant, c'est spécial, on a un /dev/ciss/c0d0...

En tout cas, les devices /dev/mdX, c'est pour le RAID logiciel, géré par le noyau Linux.
Je confirme ... Je viens juste d'installer une debian sur un
poweredge2850. Tu definis dans le bios de la carte RAID ton array et il
sera vu comme un disque SCSI donc /dev/sdx sur lequel tu vas creer tes
FS. Tu peux egalement attribuer un HD en spare directement et qui
restera la inutilise et si jamais un des disques lache, celui-ci sera
automatiquement remplace par le "Hot Spare".

Cdt,

Oooops mauvaise manip sous vim :(

Desole ...


--
Guy Roussin

UMR TETIS "Territoires, Environnement, Teledetection et Information  Spatiale"

Maison de la Télédétection en Languedoc Roussillon
500, rue J.F. Breton
34093 MONTPELLIER Cedex 5

tél: 04.67.54.87.46 fax: 04.67.54.87.00
mailto:guy.roussin@teledetection.fr


Reply to: