[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Wifi, ndiswrapper, linksys Wireless-G



Oups - pas ath0 - desole - mauvaise habitude liee a madwifi. C'est plutot un truc du genre rausb0. Bref, je te laisse verifier.
A+, JD.

Jean-Damien Durand a écrit :
D'apres mes souvenirs le make install cree un alias en utilisant /etc/modprobe.conf. Enleve ce fichier.
Cree un nouveau fichier du genre:
/etc/modprobe.d/rt2570
dans lequel tu mets:
alias ath0 rt2570

Ensuite tu fais: depmod -ae

Ensuite tu fais: modprobe rt2570 (insmod c'est quand on donne un nom de fichier absolu. Pour ce qui est dans /lib/modules/`uname -r` il faut utiliser modprobe - apres un eventuel depmod si on a rajouté quelque chose).

Normalement le module doit se charger tout seul. Verifie dans /var/log/syslog ou lsmod. Il devra probablement meme dire qu'il a trouve un hardware qui correspond.

Apres tu n'as plus qu'a configurer une interface qui portera le nom ath0
dans /etc/network/interfaces.

A+, JD.

Toto Capuccino a écrit :
Salut JD et merci pour ta disponibilité.
Je crois que je vais avoir besoin de clarification :

En effet le modèle que je possède est le plus récent, et d'après le site serialmonkey le driver est le rt2570. J'ai donc téléchargé le tar.gz sur leur site, décompressé dans /usr/src et lancé le make puis le make install/

J'ai bien un rtl2570.ko dans mon /usr/lib/modules/2.6.15-camel/extra mais je bloque sur insmod:
cant read 'rt2570': No such file or directory.


2006/3/15, Jean-Damien Durand <Jean-Damien.Durand@cern.ch <mailto:Jean-Damien.Durand@cern.ch>>:

    On Tuesday 14 March 2006 16:04, Toto Capuccino wrote:
     > Bonjour,
     >
     > Je voudrais installer une carte wifi externe lynksis Wireless-G
    WUSB54G en
     > usb.
     > Après googueulisation, je suis tombé sur un tuto
     >
http://www.netdigix.com/downloads/debian-linksys-wireless-howto.txt qui
     > fait référence à des liens erronés notamment pour le
    téléchargement de
     > ndiswrapper-bcm94306.
     > Je ne trouve pas ce paquetage.
     > J'ai fait un apt-cache search ndiswrapper et tenté une
    installation de
     > ndiswrapper-modules et utils mais je ne vois que la version
    2.6.8-2 et par
     > ailleurs même en essayant d'installer celle-là, apt parle de
    dépendances
     > non statisfaites entre ndiswrapper-modules et utils....

    Ndiswrapper c'est plutot quand on n'a plus le choix - ce qui arrive.
    Un google sur ton matos (tu as dis:  WUSB54G , ce que je traduis en:
http://www.linksys.com/servlet/Satellite?c=L_Product_C2&childpagename=US%2FLayout&cid=1115416827517&pagename=Linksys%2FCommon%2FVisitorWrapper <http://www.linksys.com/servlet/Satellite?c=L_Product_C2&childpagename=US%2FLayout&cid=1115416827517&pagename=Linksys%2FCommon%2FVisitorWrapper>
    )
    dit qu'il y a plusieurs versions de ladite carte, avec un chipset
    etant ralink
pour la derniere version (v4), ou broadcom. Un unzip du driver linksys
    confirme ralink pour la derniere version:

    % find /tmp/WUSB54Gv4_20050503/Drivers
    /tmp/WUSB54Gv4_20050503/Drivers
    /tmp/WUSB54Gv4_20050503/Drivers/WUSB54Gv1
    /tmp/WUSB54Gv4_20050503/Drivers/WUSB54Gv1/WUSB209x.sys
    /tmp/WUSB54Gv4_20050503/Drivers/WUSB54Gv1/WUSB20XP.sys
    /tmp/WUSB54Gv4_20050503/Drivers/WUSB54Gv1/WUSB54G.cat
    /tmp/WUSB54Gv4_20050503/Drivers/WUSB54Gv1/WUSB54G.inf
    /tmp/WUSB54Gv4_20050503/Drivers/WUSB54Gv2
    /tmp/WUSB54Gv4_20050503/Drivers/WUSB54Gv2/WUSB54GV2.cat
    /tmp/WUSB54Gv4_20050503/Drivers/WUSB54Gv2/WUSB54GV2.inf
    /tmp/WUSB54Gv4_20050503/Drivers/WUSB54Gv2/WUSBG9x.sys
    /tmp/WUSB54Gv4_20050503/Drivers/WUSB54Gv2/WUSBGXP.sys
    /tmp/WUSB54Gv4_20050503/Drivers/WUSB54Gv4
    /tmp/WUSB54Gv4_20050503/Drivers/WUSB54Gv4/rt2500usb.cat
    /tmp/WUSB54Gv4_20050503/Drivers/WUSB54Gv4/rt2500usb.inf
    /tmp/WUSB54Gv4_20050503/Drivers/WUSB54Gv4/rt2500usb.sys

1/ Verifie la version de ton matos. Tu as de fortes changes d'avoir la
    derniere mouture, i.e v4 -> ralink chipset -> Va voir sur
http://rt2x00.serialmonkey.com . A priori dans ton cas ce sera rt2570.
    2/ Si tu as un ancienne version de ce matos, fouille un peu plus
    dans google.

    A+, JD.




--
Le bon sens est la chose du monde la mieux partagée.





Reply to: