[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: message bizarre en console



* steph <stephane.peltier6@wanadoo.fr> [2005-07-19 20:04] :
> 
> >>j'ai ce message 
> >>qui s'affiche en continu :
> >>
> >>w1_driver w1_bus_master1: No devices present on the wire.
> >>
> >>   
> >>
> >
> >Ces messages se rapportent au pilote w1 gérant le bus 1-fil Dallas
> >("Dallas's 1-wire bus"),
> >Si tu n'as pas ce bus dans ta machine (aucune idée de la façon dont il
> >existe), tu peux sans problème supprimer le module
> >Fred
> >
> > 
> >
> Je reviens un peu tard avec cette affaire ...
> 
> J'ai en effet ces modules chargés au boot :
> 
> $ lsmod | grep w1
> matrox_w1               4000  0
> wire                   19984  1 matrox_w1
> 
> 
> Problème : je ne sais pas comment désactiver ce chargement auto ?
> 
> Que dois-je faire ?

Il faudrait déterminer comment ces modules sont chargés au démarrage.

Les "coupables" possibles sont : hotplug, discover, le fichier
/etc/modules, l'un des fichiers de /etc/mod*.

- Pour le fichier /etc/module, il suffit d'enlever le nom du module du
  fichier.

- Pour hotplug, tu peux ajouter le nom du module à
 /etc/hotplug/blacklist.

- Pour discover, il faut ajouter une directive "skip <nom_module>" dans
  /etc/discover.conf (ou /etc/discover.conf-2.6 pour les noyaux 2.6).

- Pour les fichiers /etc/mod*, cela dépend du fichier précis contenant
  le nom du module.


Fred

-- 
Comment poser les questions de manière intelligente ?
http://www.gnurou.org/documents/smart-questions-fr.html
Comment signaler efficacement un bug ?
http://www.chiark.greenend.org.uk/~sgtatham/bugs-fr.html



Reply to: