[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [Debian] libsafe



* Marc Haber <debian-user-de.jfl.de@marc-haber.de> wrote:
> die libsafe ist laut Description: ein Wrapper um gefährliche
> libc-Versionen, mit der man weniger anfällig gegen Buffer Overflows
> ist. Was mir aber aus der Source Package (installiert hab' ich's noch
> nicht) nicht klar wird: Müssen die Programme auf dem Rechner irgendwie
> speziell gegen die libsafe gebaut werden, oder laufen nach der
> Installation (+reboot?) alle Programme automatisch unter dem Schutz
> der Libsafe?

Nein, die libsafe wird ueber LD_SO_PRELOAD oder /etc/ld.so.preload
einfach mit in jedes Programm reingeklingt das gestartet wird.  Man muss
ausser der libsafe nix kompilieren.

> Arbeitet hier jemand mit der Libsafe, wie sind die Erfahrungen?

Ja, schon seit einer Weile, hatte bis vor ein paar Tagen noch 1.3 auf
meinen Rechnern, habe dann auf 2.0 upgedatet.  Mit 2.0 laesst sich
allerdings XFree86 nicht mehr starten (zumindest bei mir), weshalb ich
die Kisten auf denen ich X benoetige wieder auf 1.4 downgegradet habe.


Norbert

Attachment: pgpM9Jyfu9pHw.pgp
Description: PGP signature


Reply to: