[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

icc C++ problems on Debian 2.4.27-1-686-smp

Folks - this is essentially a question of how to install Intel compilers on a Debian box, something I would think is solved but...

I've tried debian-users for help but to no avail. I believe this list is more tuned to people using compilers - if not, can you point me in a better direction? And, for the record, I have reported this issue to Intel but am awaiting a reply...

I have just installed 'testing' on my dual Xeon. I downloaded a suitable SMP kernel from backports. Thus I have:

m@r:~/src/netcdf-3_6_0-beta6/src$ uname -a
Linux ratty 2.4.27-1-686-smp #1 SMP Fri Sep 3 06:34:36 UTC 2004 i686 GNU/Linux

I need to use the Intel compilers. (I should add that I've not had any of the below problems when I installed the Intel C/C++ and Fortran compilers on a RedHat box.) I followed Intel's instructions as per their "Platform Notes: Using Intel C++ Compiler on Unsupported Operating Systems". (This was essentially using 'alien' to convert rpm->deb, then dpkg and then sed INSTALLDIR to the name of the actual install directory for all .sh scripts)

Things looked fine. I compiled up 'mpich' and have used.

However, when I tried to compile code yesterday that has C++ headers in (eg "#include <iostream>") it fails to find them.

A simple example (thanks to Kamaraju Kusumanchi on the d-u list):

m@r:/tmp$ icc sizes.cpp
sizes.cpp(1): catastrophic error: could not open source file "iostream"
 #include <iostream>

compilation aborted for sizes.cpp (code 4)
m@r:/tmp$ icc -cxxlib-icc sizes.cpp
m@r:/tmp$ ./a.out

(and same behaviour if I replace icc with icpc).

I also note that:

m@r:~/src/l_cc_p_8.1.021$ /lib/libc.so.6;ls -lt /lib/libc.so.6;ls -lt /lib/libc-2.3.2.so
bash: /lib/libc.so.6: Permission denied
lrwxrwxrwx  1 root root 13 2004-11-11 18:34 /lib/libc.so.6 -> libc-2.3.2.so
-rw-r--r--  1 root root 1244080 2004-10-13 20:40 /lib/libc-2.3.2.so

And finally, that even when I put the -cxxlib-icc flag with my compilation I still get (more & more severe!) error messages at link time, eg
icc -o nctst -g -O2 -Vaxlib nctst.o libnetcdf_c++.a -L../libsrc -lnetcdf
icc: Command line warning: ignoring option '-V'; no argument required
nctst.o(.text+0x4d): In function `gen(char const*, int)':
/opt/intel_cc_80/include/c++/xlocnum:1088: undefined reference to `std::cerr'
nctst.o(.text+0x335): In function `gen(char const*, int)':
/opt/intel_cc_80/include/c++/ostream:212: undefined reference to `std::cerr'
nctst.o(.text+0x44f): In function `dumpatts(NcVar&)':
/home/michael/src/netcdf-3_6_0-beta6/src/cxx/nctst.cpp:155: undefined reference
to `std::cout'
nctst.o(.text+0x491):/home/michael/src/netcdf-3_6_0-beta6/src/cxx/nctst.cpp:157: undefined reference to `std::cout'
nctst.o(.text+0x51d): In function `dump(char const*)':
/opt/intel_cc_80/include/c++/xlocnum:1266: undefined reference to `std::cout' nctst.o(.text+0x569):/opt/intel_cc_80/include/c++/xlocnum:908: undefined {snipped}

Thanks, Michael, Atmospheric Physics Group, Univ of Manchester (UK)

Reply to: