[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#388115: tetex-base: postinst fails, can not upgrade



On Wed, Sep 20, 2006 at 23:46 +0400, Norbert Preining wrote:
> On Wed, 20 Sep 2006 12:07:33 +0200 "Frans Pop" <elendil@planet.nl> wrote:
> >Looks like the 40jadetex.cnf.dpkg-new is there because jadetex cannot jet 
> >be configured and so the old version of the config file is still used.
> 
> Yes, this is true, it seems to be like this. BUT: Why is the snippet
> at all included in the fmtutil.cnf file??? The new update-* code ???
> added (who was it?) should make sure that the snippets with a
> .dpkg-new file are *not* included.  

I wondered about that, too.

> So could it be that tetex-* doesnt call update-fmtutil at the
> beginning of the postinst script? this would explain why this
> happened, at least this is my semi-qualified opinion from the
> crystal-ball ... 

Your crystal ball is good. Where did you get it? Anyway, it is indeed
the case that tetex-base.postinst does not call update-fmtutil before
caling fmtutil-sys, which is probably wrong.

> Ahh yes Ralf: I assume that the original bug report did go to the
> maintainer.

But this is a bug against tetex-base. An debian-tex-maint is the
maintainer of that package. We have had theproblem before. Typically
with large messages. Unfortunately the latter are typical when building
formats fails and people do what they are told, ie include the log file.
Oh well ...

> What I dont understand is why the NMU is numbered -7? 

The last jadetex upload wasn't an NMU.

cheerio
ralf



Reply to: