[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#321094: solved (was: Re: Bug#321094: tetex-bin: Usage of some fonts fails)

Frank Küster schrieb am 05.08.2005 12:31:

> Christoph Bier <christoph.bier@web.de> wrote:
>>>You seem to have some stuff in HOMETEXMF, but much
>>>of the configuration files in /etc/texmf.  This might cause some
>>This was necessary for teTeX 2 because it did not search for map and
>>enc files in HOMETEXMF. Might this really confuse teTeX 3.0 now? I
>>always installed the font files according to Walter's instructions
>>for teTeX 2. And now some work, some don't ...
> I don't know whether it confuses teTeX 3.0, it's just one piece that
> contributes to the puzzle...  What could in fact cause confusion is if
> you *now* use both upmap and updmap-sys, creating different information

I deleted all my "own" map files in $TEXMFMAIN, so that they only
reside in $TEXMFHOME again.

>>>What is actually the output of 
>>>kpsewhich --progname=pdflatex pdftex.map
>>>is it in HOMETEXMF, and is it the right one?

After I run

$ updmap

as normal user chris---not as root!---there's a pdftex.map in
/home/chris/.texmf-var/fonts/map/pdftex/updmap/ and all my own fonts
are found by pdflatex. So, it works now :-)!


> I suggest that you also ask on de.comp.text.tex or similar for help;
> especially when there are also some problems with the manually installed
> teTeX-3.0. 

There were no problems with the manually installed teTeX 3.0 on my
laptop. All my fonts worked and I used the same $TEXMFHOME as on my
desktop. So I had a working installation of teTeX 3.0 that showed me
everything is right in $TEXMFHOME. The problem was that calling
updmap as root did not create
/home/chris/.texmf-var/fonts/map/pdftex/updmap/ and its content and
that /var/lib/texmf/fonts/map/pdftex/updmap/pdftex.map was not
correctly updated (even with all map files in $TEXMFMAIN)---and is
still not even after calling updmap as root. But without
/var/lib/texmf/fonts/map/pdftex/updmap/pdftex.map is found by
pdflatex called by a normal user and it doesn't contain the right

As long as updmap called by a normal user can't write
/usr/local/share/texmf/ls-R I would except updmap called by root
would do the job for every user, i.e. creating a correct

(La)TeX-FAQ: http://www.dante.de/faq/ +++ Minimalbeispiel erstellen
und Einführung in de.comp.text.tex: http://www.latex-einfuehrung.de/
+++ Veraltete Befehle, Pakete und andere Fehler:
+++ Typografie-Regeln: http://www.zvisionwelt.de/typokurz.pdf (1.4)

Reply to: