[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: apt-get dist-upgrade broken: udev

On Mon, 19 Sep 2005, Brandon Kuczenski wrote:

Last night I was brave and attempted an apt-get dist-upgrade before I went to sleep. When I woke up this morning, the program had exited on an error.

The error was in installing udev_0.068-2_i386.deb -- it complained that it needed a kernel >= 2.6.12 to install, and promptly quit. I assume that the specified kernel is part of the dist-upgrade, but I cannot find a kernel-image-2.6.1[2-9] debfile in my /var/cache/apt/archive directory.

I have solved my problem, somewhat magically.

I installed a 2.6.12 kernel but I couldn't get my wireless firmware module to install ...

 { this is OT:
I rebuilt the acx_pci module with the new kernel headers, but when I tried to install it, it reported that it "disagrees about version of symbol struct_module". The help page about acx100 reports that this happens either when the headers used to compile the module don't match the running kernel (not true) or when the compilers used to build the kernel and the module were different versions. My gcc is 4.0.1-2 and Debian's is 4.0.1-6. So I guess that must be it.

If you have an idea how to solve this, please contact me [probably off-list; I don't really know the etiquette].


Anyway, so I went back to 2.6.11 and tried 'dpkg --purge udev', expecting it to give dependency errors. It did not. When I then did 'apt-get -f install' it installed the new udev without complaint, I suppse because it detected the 2.6.12 kernel on the machine (even though it wasn't running), and during configuration, reported "udev requires kernel version >= 2.6.12. Not starting." The rest of apt-get dist-upgrade went without a hitch, and I am now running on a dist-upgraded box.

Thanks for everyone's help.  Really, I am seriously grateful.


Reply to: