[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

How to recover RAID-1 array when "./MAKDEV md" fails!?

I'd like to thank everyone on the list who has helped me out so far. 
After repeated additional attempts to install Sarge rc2 (Feb 28 snapshot)
on 2 SCSI disks with 4 partitions mirrored in a RAID-1 array (one array an
LVM), I punted LVM and dropped back to two partitions set to RAID
autodetect, then software RAID-1 on / and swap.  (When I defined the disk
partitions, I defined 2.0 GB at the end of each disk for "swap" first --
so these are /sda1 and /sdb1, then used the rest at the front for "root"
which became /sda2 and sdb2.  But md0 was / and md1 was swap.)  I used
GRUB as LILO complained about being installed in a partition that was not
"active."  This installed okay, but I only got one successful boot of both
RAID arrays.  Here is where things get interesting...

The kernel messages were not all that helpful.  md detected some problem
with md1 on that first reboot and resync'ed successfully.  But on the next
boot there was no message at all -- md1 just seemed to disappear.  So I
still have a functional system, but no swap area.  I am using kernel
2.6.8-2-686-smp and this has udev, not devfs.  I tried to recreate the
array using "mdadm -Cv -l1 -n2 /dev/md1 /dev/sd{a,b}1" and got a message
from mdadm saying it was in manage mode.  How useful.  I also tried using
assemble mode, and then later added the --auto switch.  Here is where udev
comes into the picture.  mdadm still would not assemble the array,
complaining that /dev/md1 did not exist.  Sure enough, the only md device
in /dev was md0.  So it appears that udev scrubbed md1 out of existence
after the second boot.  I then tried to create md1 manually (using advice
that works for Fedora) by following the thread here:

This did not work.  After executing "./MAKEDEV md" as root in the /dev
directory, I still had only md0.  So now I have md/mdadm refusing to
create or assemble an array because the device file does not exist, and I
am unable to create the device file manually.  If anyone can suggest a way
out of this -- short of another installation -- I'll be grateful.

BTW, considering how much time I have already lost trying to get Sarge
installed, if anyone thinks an alternative distro is a better choice,
please say so.  My needs are for SMP, software RAID-1, and a good GNU
development environment.  Everything else is gravy.  I will say this: 
Having lost so much time (almost a month) and a dozen or so failed
installation attempts, I now have a new-found respect for, shall we say,
"commercial" operating system software.

Reply to: