[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

libusb-dev upgrade broken?


I dist-upgraded my Woody system today after several weeks. I had 217
upgraded packages, 180MB to get. After downloading everything, it
failed like this:

Preparing to replace libusb-dev 1:0.1.4-2 (using .../libusb-dev_1%3a0.1.5-4_i386
.deb) ...^M
Unpacking replacement libusb-dev ...^M
dpkg: error processing /var/cache/apt/archives/libusb-dev_1%3a0.1.5-4_i386.deb (
 trying to overwrite `/usr/lib/libusb.la', which is also in package libusb0^M
Errors were encountered while processing:^M
E: Sub-process /usr/bin/dpkg returned an error code (1)^M

To get anything done, I went into dselect, put libusb-dev on hold, ran
'apt-get -f dist-upgrade' again and everything was okay (well, sort
of, I now have really small, cruddy looking fonts, and XEmacs no
longer lets me read mail with vm, but that is another story).

I then used dselect to unhold libusb-dev, still the same
problem. It seems that libusb-dev needs libusb-0.1.4, which replaces
libusb0. I was able to purge libusb0, and then everything worked out.

Any one know what the problem with libusb-0.1.4 is?


To UNSUBSCRIBE, email to debian-testing-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: