[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

procps/top smp cpu reporting

I'm having a problem getting /usr/bin/top from procps 2.0.7-8  debian
package to report multiple CPU's in it's output.  I am hopeful this is 
somehow user error in getting this correctly set up.

The system in question is an Intel Pentium Pro running kernel 
2.4.17 SMP.  I can send more details like kernel config if that
is helpful in determining the root of the problem.  
Processor #1 Pentium(tm) Pro APIC version 17
Processor #0 Pentium(tm) Pro APIC version 17

I tried downloading source code for procps and building.  According
to the NEWS file included in the procps source distribution, libproc
has been modified to provide SMP support.  Hmmmmmmm....

When built from source, I do indeed get displays of my two CPU's and
their respective states.  However, it seg faults somewhere in meminfo 

 09:52:10 up 10 days, 19:07,  9 users,  load average: 0.00, 0.00, 0.00
88 processes: 0 sleeping, 0 running, 0 zombie, 0 stopped
CPU0 states:  0.0% user,  0.0% system,  0.0% nice, 100.0% idle
CPU1 states:  0.0% user,  2.0% system,  0.0% nice, 97.0% idle
Segmentation fault

I am hopeful that someone else has already seen and solved this problem,
but a quick search of the debian site pages indicates the issue has not
yet been raised.....

Suggestions/thoughts/ideas most welcome.


Nancy Davis

Unix Sys Admin
School of Computing
University of Utah

To UNSUBSCRIBE, email to debian-testing-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: