[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Install report (pre-2.2.6 CVS)


I got a chance to install my set of boot floppies (which is just before
2.2.6, and more or less the same as Christian Meder's except for the initial
boot process) on an AlphaServer DS10 today.  It was an ... interesting ...

I have a feeling some of these problems have already been solved, or are
solved on i386 and will be fixed once Alpha catches up.  Anyhow, here goes...

1) The keyboard is, well, wrong in the shell on vt2.  Neither backspace nor
delete works properly.  I don't exactly know why this is yet...

2) "mkdir -p" in busybox doesn't work, which means that you can't specify a
mount point in /target for a partition where no directory exists - this is
probably not a big concern though (I have a special case where I am sharing
/home and /usr/local between Red Hat and Debian installations)

3) /dev/fd0 doesn't exist on the root.bin disk - I'll fix this one :)  Not
sure if this is a problem on Christian's disks.

4) On Christian's disks, "linux" on the root.bin is a symbolic link to
somewhere in /var/tmp/boot-floppies, which obviously doesn't exist... I
don't have that problem.

5) root.bin doesn't have aboot on it.  I'll fix this, and also make the
"create a boot floppy" and "make the system bootable from the hard disk"
options use it on SRM systems.  (I should note that SRM seems to be the
preferredd way to boot Linux on Alphas these days, since there is no MILO
for any current subarchitectures, and it appears that Compaq has no
intentions of supporting it on them).

6) Selecting DHCP/BOOTP in the network configuration failed to write an
entry for localhost to /etc/hosts.  This made lots of things fail once the
system was installed, including exim's postinst.

7) The base system's networking config tried to start dhcpcd-sv instead of

8) I still do not understand why we have both console-tools and kbd, and why
dselect wanted to install kbd.  Then, console-tools' postinst hung - it said
"you have not selected a keymap, so I will use the default", and spawned
kbdconfig.  When I answer the kbdconfig prompt, it just sits there.  (Might
I add that kbdconfig is really evil on powerpc and m68k, since they
don't always use standard PC keyboards, and thus reloading the "default"
keymap mangles the keyboard layout horribly)

9) The apt configurator is really nice, however, it should be possible to
skip apt configuration entirely (such as if network configuration has failed
somehow, and thus no archives are accessible).  Also, it would be nice if
you could also select non-US in the apt configuration (can you?  I couldn't
see a way)

To UNSUBSCRIBE, email to debian-testing-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: