[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#502444: sshd fails at boot-time following reload by /etc/network/if-up.d/openssh-server presumably due to race condition

Thanks for the patch. It doesn't solve the problem. I reverted my
changes back to the original state, and then rebooted to make sure the
problem occurs. Then I applied your patch and rebooted, but the error
occurred again, but only sometimes.

Before your patch, when it failed, it logged this:

Jan 13 23:56:50 leeloo3 sshd[2052]: Server listening on port 22.
Jan 13 23:56:50 leeloo3 sshd[2052]: Received SIGHUP; restarting.

or that:

Jan 13 23:46:40 leeloo3 sshd[2323]: Server listening on port 22.
Jan 13 23:46:50 leeloo3 sshd[2323]: Received signal 15; terminating.

or that:

 Jan 13 22:16:51 leeloo3 sshd[2134]: Server listening on port 22.
Jan 13 22:16:51 leeloo3 sshd[2142]: error: Bind to port 22 on
failed: Address already in use.

When it worked, it just logged the first line of those.

Now after applying your patch, it still logs the "SIGHUP" message and
fails, or it logs only the first message and then works.

Note that during this boot process the driver for the built-in NICs,
bnx2, loads pretty late. Its last ready messages come even after the
login prompt:

bnx2: eth1 NIC Link is Up, 1000 Mbps full duplex
bnx2: eth0 NIC Link is Up, 1000 Mbps full duplex

The /etc/network/interfaces contains "allow-hotplug" for eth0 and eth1.
I tried adding bnx2 to /etc/modules, causing the module to be loaded
sooner, and couldn't seem to make it fail that way. But I'm still
rebooting that machine over and over, trying to get somewhat reliable
information. (race condition)

Kevin Price

Attachment: signature.asc
Description: OpenPGP digital signature

Reply to: