[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#401483: marked as done (openssh-client: support -K option)

Your message dated Wed, 06 Dec 2006 23:32:03 +0000
with message-id <E1Gs6F9-00007U-VV@ries.debian.org>
and subject line Bug#401483: fixed in openssh 1:4.3p2-7
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

--- Begin Message ---
Package: openssh-client
Version: 1:4.3p2-6
Severity: wishlist
Tags: patch

The attached patch adds support for the -K option, which enables GSSAPI
credential delegation even if it's normally disabled in the configuration.
It's the converse of -k (and more useful).  This flag is already supported
by ssh-krb5.

-- System Information:
Debian Release: 4.0
  APT prefers testing
  APT policy: (990, 'testing'), (500, 'unstable'), (1, 'experimental')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.18-1-686
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)

Versions of packages openssh-client depends on:
ii  adduser  3.99                            Add and remove users and groups
ii  debconf  1.5.8                           Debian configuration management sy
ii  dpkg     1.13.24                         package maintenance system for Deb
ii  libc6    2.3.6.ds1-8                     GNU C Library: Shared libraries
ii  libcomer 1.39+1.40-WIP-2006.11.14+dfsg-1 common error description library
ii  libedit2 2.9.cvs.20050518-2.2            BSD editline and history libraries
ii  libkrb53 1.4.4-4su1                      MIT Kerberos runtime libraries
ii  libncurs 5.5-5                           Shared libraries for terminal hand
ii  libssl0. 0.9.8c-3                        SSL shared libraries
ii  passwd   1:                    change and administer password and
ii  zlib1g   1:1.2.3-13                      compression library - runtime

openssh-client recommends no packages.

-- no debconf information
diff -ru openssh-4.3p2.orig/ssh.1 openssh-4.3p2/ssh.1
--- openssh-4.3p2.orig/ssh.1	2006-12-03 11:28:54.000000000 -0800
+++ openssh-4.3p2/ssh.1	2006-12-03 11:31:16.000000000 -0800
@@ -43,7 +43,7 @@
 .Nd OpenSSH SSH client (remote login program)
 .Nm ssh
-.Op Fl 1246AaCfgkMNnqsTtVvXxY
+.Op Fl 1246AaCfgKkMNnqsTtVvXxY
 .Op Fl b Ar bind_address
 .Op Fl c Ar cipher_spec
 .Oo Fl D\ \&
@@ -314,6 +314,8 @@
 .Fl i
 options (and multiple identities specified in
 configuration files).
+.It Fl K
+Enables forwarding (delegation) of GSSAPI credentials to the server.
 .It Fl k
 Disables forwarding (delegation) of GSSAPI credentials to the server.
 .It Fl L Xo
diff -ru openssh-4.3p2.orig/ssh.c openssh-4.3p2/ssh.c
--- openssh-4.3p2.orig/ssh.c	2006-12-03 11:28:54.000000000 -0800
+++ openssh-4.3p2/ssh.c	2006-12-03 11:30:47.000000000 -0800
@@ -157,7 +157,7 @@
-"usage: ssh [-1246AaCfgkMNnqsTtVvXxY] [-b bind_address] [-c cipher_spec]\n"
+"usage: ssh [-1246AaCfgKkMNnqsTtVvXxY] [-b bind_address] [-c cipher_spec]\n"
 "           [-D [bind_address:]port] [-e escape_char] [-F configfile]\n"
 "           [-i identity_file] [-L [bind_address:]port:host:hostport]\n"
 "           [-l login_name] [-m mac_spec] [-O ctl_cmd] [-o option] [-p port]\n"
@@ -244,7 +244,7 @@
 	while ((opt = getopt(ac, av,
-	    "1246ab:c:e:fgi:kl:m:no:p:qstvxACD:F:I:L:MNO:PR:S:TVw:XY")) != -1) {
+	    "1246ab:c:e:fgi:kl:m:no:p:qstvxACD:F:I:KL:MNO:PR:S:TVw:XY")) != -1) {
 		switch (opt) {
 		case '1':
 			options.protocol = SSH_PROTO_1;
@@ -298,6 +298,9 @@
 		case 'k':
 			options.gss_deleg_creds = 0;
+		case 'K':
+			options.gss_deleg_creds = 1;
+			break;
 		case 'i':
 			if (stat(optarg, &st) < 0) {
 				fprintf(stderr, "Warning: Identity file %s "

--- End Message ---
--- Begin Message ---
Source: openssh
Source-Version: 1:4.3p2-7

We believe that the bug you reported is fixed in the latest version of
openssh, which is due to be installed in the Debian FTP archive:

  to pool/main/o/openssh/openssh-client-udeb_4.3p2-7_powerpc.udeb
  to pool/main/o/openssh/openssh-client_4.3p2-7_powerpc.deb
  to pool/main/o/openssh/openssh-server-udeb_4.3p2-7_powerpc.udeb
  to pool/main/o/openssh/openssh-server_4.3p2-7_powerpc.deb
  to pool/main/o/openssh/openssh_4.3p2-7.diff.gz
  to pool/main/o/openssh/openssh_4.3p2-7.dsc
  to pool/main/o/openssh/ssh-askpass-gnome_4.3p2-7_powerpc.deb
  to pool/main/o/openssh/ssh-krb5_4.3p2-7_all.deb
  to pool/main/o/openssh/ssh_4.3p2-7_all.deb

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 401483@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Colin Watson <cjwatson@debian.org> (supplier of updated openssh package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.7
Date: Wed,  6 Dec 2006 23:00:49 +0000
Source: openssh
Binary: ssh-askpass-gnome ssh-krb5 openssh-client-udeb ssh openssh-server openssh-client openssh-server-udeb
Architecture: source powerpc all
Version: 1:4.3p2-7
Distribution: unstable
Urgency: medium
Maintainer: Matthew Vernon <matthew@debian.org>
Changed-By: Colin Watson <cjwatson@debian.org>
 openssh-client - Secure shell client, an rlogin/rsh/rcp replacement
 openssh-client-udeb - Secure shell client for the Debian installer (udeb)
 openssh-server - Secure shell server, an rshd replacement
 openssh-server-udeb - Secure shell server for the Debian installer (udeb)
 ssh        - Secure shell client and server (transitional package)
 ssh-askpass-gnome - under X, asks user for a passphrase for ssh-add
 ssh-krb5   - Secure shell client and server (transitional package)
Closes: 335259 335276 390986 391248 398436 401483
 openssh (1:4.3p2-7) unstable; urgency=medium
   [ Colin Watson ]
   * Ignore errors from usermod when changing sshd's shell, since it will
     fail if the sshd user is not local (closes: #398436).
   * Remove version control tags from /etc/ssh/moduli and /etc/ssh/ssh_config
     to avoid unnecessary conffile resolution steps for administrators
     (thanks, Jari Aalto; closes: #335259).
   * Fix quoting error in configure.ac and regenerate configure (thanks, Ben
     Pfaff; closes: #391248).
   * When installing openssh-client or openssh-server from scratch, remove
     any unchanged conffiles from the pre-split ssh package to work around a
     bug in sarge's dpkg (thanks, Justin Pryzby and others; closes: #335276).
   [ Russ Allbery ]
   * Create transitional ssh-krb5 package which enables GSSAPI configuration
     in sshd_config (closes: #390986).
   * Default client to attempting GSSAPI authentication.
   * Remove obsolete GSSAPINoMICAuthentication from sshd_config if it's
   * Add ssh -K option, the converse of -k, to enable GSSAPI credential
     delegation (closes: #401483).
 976d80c02546f5b6b8b9254a97cfaec3 1000 net standard openssh_4.3p2-7.dsc
 c38ee430b3f59225b9e96e7ad7529e3c 254719 net standard openssh_4.3p2-7.diff.gz
 f61c287091686f202980ea0981276324 1054 net extra ssh_4.3p2-7_all.deb
 1bcf5661b3340ff11b00be8f293c8a5f 90614 net extra ssh-krb5_4.3p2-7_all.deb
 91a45b129bbf56e07a40e717184b70e4 643674 net standard openssh-client_4.3p2-7_powerpc.deb
 eb03bd0b385940aafaf038659479241a 231148 net optional openssh-server_4.3p2-7_powerpc.deb
 a1e8ffceecf9d60bdcc6dcf8e421064a 100002 gnome optional ssh-askpass-gnome_4.3p2-7_powerpc.deb
 018cb1112ab2bcb45d874a5499184b12 166780 debian-installer optional openssh-client-udeb_4.3p2-7_powerpc.udeb
 1a139b804d28fdc4bb993667f9150747 169888 debian-installer optional openssh-server-udeb_4.3p2-7_powerpc.udeb
Package-Type: udeb

Version: GnuPG v1.4.5 (GNU/Linux)


--- End Message ---

Reply to: