[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Latest netinst iso

On 08/07/2018 05:52 AM, Frank Scheiner wrote:
On 08/07/2018 11:02 AM, Thomas Schmitt wrote:

Fred wrote:
[...] DVD drive [...]

Frank Scheiner wrote:
if a specific CDROM drive and
the assumed "compatible" driver don't work together, this results in a
situation like yours

Oh, sorry for my ignorance, as my Ultra 10 has a CDROM drive installed instead of a DVDROM drive I was mislead to write "CDROM drive" (although Fred had problems with a DVDROM drive) but that shouldn't make much of a difference, or?

All DVD capable drives at IDE are supposed to work by the SCSI/MMC protocol via ATAPI. So there is few chance that the drive itself is not matched by
the kernel's sr driver.

If the drive does not show up as Linux device, i would rather bet on
a driver mismatch with the IDE/ATAPI controller of the machine.

But interestingly the assumed same controller driver works well for Gregor's and my Ultra 10 and it also works well when Fred uses a CDROM drive.

What could be the reason for that?

Maybe Fred's Ultra 10 is using another revision of the CMD 646 IDE controller - my Ultra 10 for example uses a CMD 646U - or a DMA mode is used for the DVDROM drive that is not working correctly with the CMD 646.

I seem to remember to have read about problems with CMD IDE controllers used in some Sun machines in the past, but cannot find the info now. But I did find an interesting post on the NetBSD sparc list ([1]), which gives some background info on different revisions of CMD 646 controllers. So every CMD 646 controller below 646U2 seems to do things wrong with UltraDMA modes or it only works with very specific drives.

[1]: http://mail-index.netbsd.org/port-sparc/2001/12/16/0005.html

And it could be that the CDROM drives used (by me and later also by Fred) just support MWDMA or PIO modes that work well with all CMD 646 revisions. That the DVDROM drive works when used from the firmware could mean that OBP generally does not activate DMA or specifically disables it for the CMD 646 controller.


UPDATE: I just tested an UltraDMA2 (UDMA/33) capable DVDROM drive in my Ultra 10 and didn't have any problems. But it also looks like the controller driver specifically disables UltraDMA modes and only configures a maximum of MWDMA2:
[   35.255080] scsi host0: pata_cmd64x
[   35.300865] hme 0000:01:01.1 enp1s1f1: renamed from eth0
[   35.369538] scsi host1: pata_cmd64x
[ 35.432494] ata1: PATA max MWDMA2 cmd 0x1fe02c00000 ctl 0x1fe02c00008 bmdma 0x1fe02c00020 irq 14 [ 35.542765] ata2: PATA max MWDMA2 cmd 0x1fe02c00010 ctl 0x1fe02c00018 bmdma 0x1fe02c00028 irq 14
[   35.653931] pata_cmd64x: active 10 recovery 10 setup 3.
[   35.653947] pata_cmd64x: active 10 recovery 10 setup 3.
[   35.855471] ata1.01: both IDENTIFYs aborted, assuming NODEV
[   35.858949] ata1.00: ATA-5: WDC WD800AB-00CBA0, 03.06A03, max UDMA/100
[   35.940006] ata1.00: 156301488 sectors, multi 0: LBA
[   36.003451] pata_cmd64x: active 3 recovery 1 setup 1.
[   36.003471] pata_cmd64x: active 3 recovery 1 setup 1.
[   36.009072] ata1.00: configured for MWDMA2
[ 36.061880] scsi 0:0:0:0: Direct-Access ATA WDC WD800AB-00CB 6A03 PQ: 0 ANSI: 5
[   36.169978] pata_cmd64x: active 10 recovery 10 setup 3.
[   36.169992] pata_cmd64x: active 10 recovery 10 setup 3.
[   36.327225] ata2.00: ATAPI: SAMSUNG DVD-ROM SD-616Q, F401, max UDMA/33
[   36.409059] pata_cmd64x: active 3 recovery 1 setup 1.
[   36.409075] pata_cmd64x: active 3 recovery 1 setup 1.
[   36.411667] ata2.00: configured for MWDMA2
[ 36.465435] scsi 1:0:0:0: CD-ROM SAMSUNG DVD-ROM SD-616Q F401 PQ: 0 ANSI: 5 [ 36.642314] sd 0:0:0:0: [sda] 156301488 512-byte logical blocks: (80.0 GB/74.5 GiB)
[   36.745958] sd 0:0:0:0: [sda] Write Protect is off
[   36.807635] sd 0:0:0:0: [sda] Mode Sense: 00 3a 00 00
[ 36.807957] sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA [ 36.926295] sr 1:0:0:0: [sr0] scsi3-mmc drive: 16x/48x cd/rw xa/form2 cdda tray
[   37.023810] cdrom: Uniform CD-ROM driver Revision: 3.20
[   37.098287] sr 1:0:0:0: Attached scsi CD-ROM sr0
[   37.250888]  sda: sda1 sda2 sda3
[   37.299576] sd 0:0:0:0: [sda] Attached SCSI disk

Retesting with the CDROM drive shows that it gets also configured to MWDAM2:
[   36.294580] ata2.00: ATAPI: CRD-8322B, 1.05, max MWDMA2
[   36.360599] pata_cmd64x: active 3 recovery 1 setup 1.
[   36.360615] pata_cmd64x: active 3 recovery 1 setup 1.
[   36.365323] ata2.00: configured for MWDMA2
[ 36.418764] scsi 1:0:0:0: CD-ROM LG CD-ROM CRD-8322B 1.05 PQ: 0 ANSI: 5 [ 36.605717] sr 1:0:0:0: [sr0] scsi3-mmc drive: 32x/32x cd/rw xa/form2 cdda tray
[   36.702402] cdrom: Uniform CD-ROM driver Revision: 3.20
[   37.055470] sr 1:0:0:0: Attached scsi CD-ROM sr0

So actually any support for UltraDMA in the DVDROM or CDROM drive does not seem to make a difference.


The HP DVD drive was in use on a U5 running Wheezy and worked fine. With the new Sid installation, the Sun boot prom had no trouble with the drive, the Debian boot loader had no trouble with it as it loaded the installer program. The problem showed up when the installer tried to check for a cdrom drive to continue installation.
Best regards,

Reply to: