[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: The end of my Ultrasparc 5?!?

yes, I've tried passing in init=/bin/bash but, it still trys to process the btrfs filesystem before a prompt is available.

The boot process hangs here:

[   44.070355] raid6: int64x1  xor()    43 MB/s
[   44.190108] raid6: int64x2  gen()   125 MB/s
[   44.310194] raid6: int64x2  xor()    62 MB/s
[   44.429980] raid6: int64x4  gen()   151 MB/s
[   44.550073] raid6: int64x4  xor()    80 MB/s
[   44.669932] raid6: int64x8  gen()   133 MB/s
[   44.790009] raid6: int64x8  xor()    84 MB/s
[   44.844728] raid6: using algorithm int64x4 gen() 151 MB/s
[   44.912879] raid6: .... xor() 80 MB/s, rmw enabled
[   44.973689] raid6: using intx1 recovery algorithm
[ 45.101360] xor: automatically using best checksumming function VIS
[   45.208607] crc32c_sparc64: sparc64 crc32c opcode not available.
[   45.456022] Btrfs loaded, crc32c=crc32c-generic
Scanning for Btrfs filesystems

It' will stay like this for days....

Actually looking back through my backups, I reinstalled sparc64 in March 2017, and the btrfs packages are included in the next backup. These have been installed all along, but the timeout behavior must have changed at some point.


On 01/25/2018 04:03 PM, James Clarke wrote:
On 25 Jan 2018, at 23:58, Sean Whitney <sean.whitney@gmail.com> wrote:

I recently switched from sparc to sparc64 using the cdrom drive in September.  Sometime in the last two weeks the server rebooted and when it tried to restart it hung trying to find a btrfs filesystem, which I don't have.  This seems to be a problem for PCs, but it resolves itself in 15 seconds, and is an annoyance, while my hangs indefinately.  The solution is to remove the btrfs packages installed on your system.  But I can't do this because I can't get it complete a boot to get a prompt. Both aliases silo images seem to have the same btrfs packages included. I'm not sure when the btrfs packages were installed, not knowing it was an issue, I guess I allowed them to be installed with updates.

Here is the rub, I can't seem to boot from the cdrom anymore. When I do I get the following error.

Rebooting with command: boot cdrom
Boot device: /pci@1f,0/pci@1,1/ide@3/cdrom@2,0:f  File and args:
Can't read disk label.
Can't open disk label package
Evaluating: boot cdrom

Can't open boot device

I can't boot with the net because the net install image for debian hasn't worked for ultra 5's since lenny.

Right now I've turned off the Ultra 5 for the next 12 hours to see if it makes any difference with the CDROM.

If anyone has any other suggestions as to any sort of recovery I'm all ears, otherwise I guess it's time to go to recycle.

Thanks in advance,

No idea what's causing all your issues, unfortunately. Have you tried booting
with "linux init=/bin/bash" or similar? What exact error are you getting?


The only time you should look in your neighbor's bowl it to make sure that they have enough. You don't look in your neighbor's bowl to see if you have … as much as them.
	― Louis CK

Reply to: