[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Best debian 9 repo for sparc64 packages

On 12/30/2017 12:40 AM, Tony Rodriguez wrote:
> Modified my sources to file to reflect "https://deb.debian.org/debian-ports"; then ran apt-get update.

This doesn't help with Firefox in your case for the aforementioned reasons I was talking about.

> A) firefox still doesn't install.
> "apt-get install firefox
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> Some packages could not be installed. This may mean that you have
> requested an impossible situation or if you are using the unstable
> distribution that some required packages have not yet been created
> or been moved out of Incoming.
> The following information may help to resolve the situation:
> The following packages have unmet dependencies:
>  firefox : Depends: libevent-2.0-5 (>= 2.0.10-stable) but it is not installable
>            Depends: libhunspell-1.4-0 but it is not installable
> E: Unable to correct problems, you have held broken packages."

You need to search snapshots for the packages above, e.g.:


Then right-click the path next to the sparc64 package and paste it into your sources.list:

deb http://snapshot.debian.org/archive/debian-ports/20161011T063855Z/ unstable main

Note: You have to strip off "pool-sparc64/main/h/hunspell/" and add " unstable main"
      to the URL above.

Then run apt-get update as:

# apt-get -o Acquire::Check-Valid-Until=false update

To disable the signature verification.

I recommend reading the documentation for snapshots on the website to understand
the underlying issue and how to use it properly. It's a bit confusing if you do it
the first time. Sometimes you need to specify the exact versions of the packages
you want to install, e.g. for the package "xbill":

# apt install xbill=1.2.3-1

You can see the available with:

# apt-cache policy xbill

> B) Iceweasel doesn't install

Iceweasel doesn't exist anymore.

> C) Clicking the web browser (bottom left of screen) within lxde desktop generates the following error popup.
> "Invalid desktop entry file: '/usr/share/applications/lxde-x-www-browser.desktop'"

That's because you have no package installed which provides lxde-x-www-browser.


 .''`.  John Paul Adrian Glaubitz
: :' :  Debian Developer - glaubitz@debian.org
`. `'   Freie Universitaet Berlin - glaubitz@physik.fu-berlin.de
  `-    GPG: 62FF 8A75 84E0 2956 9546  0006 7426 3B37 F5B5 F913

Reply to: