[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Updated debian-installer images


On 09/05/2017 10:21 PM, John Paul Adrian Glaubitz wrote:
For some reason the CD building process is omitting several packages
that should be included. I have not yet figured out what the problem
is. Still investigating.

Many thanks for your hard work on this.

In the meantime I tried to boot the earlier mentioned installer image also on a PRIMEPOWER 250 with SPARC64 V+ CPUs, just to check if the used Linux kernel boots the machine - the missing SILO installer wouldn't be a problem during this state.

After the previous testing I came to the conclusion that Linux seems to not support Fujitsu's SPARC64 CPUs (as per [1], "Note that Fujitsu's SPARC64 CPUs used in PRIMEPOWER family of servers are not supported due to lack of support in the Linux kernel. "), although it came pretty far for a "lack of support in the Linux kernel". But as SPARC64 V and V+ are listed on [2] and the mentioned info is from the Wheezy manual so maybe outdated, I again tried to boot with the latest image available.

[1]: https://www.debian.org/releases/wheezy/sparc/ch02s01.html.en#idp5522752

[2]: https://wiki.debian.org/Sparc64#Installing_the_Debian_SPARC64_Port

But sadly the machine also crashes early (log below), just like with the previous installer image I tested. Should this actually work?

Here's a log of a tried boot:
Fujitsu Siemens PRIMEPOWER250 2x SPARC64 V, No Keyboard
OpenBoot 3.18.1-1, 8192 MB memory installed
Ethernet address 0:b:5d:11:22:33, Host ID: 80112233.
XSCF Version: 4.12.1

{0} ok boot cdrom
Boot device: /pci@83,4000/ide@d/cdrom@0,0:f  File and args:
SILO Version 1.4.14

                  Welcome to Debian GNU/Linux sid!

This is a Debian installation CDROM, built on 20170903-09:49.
Keep it once you have installed your system, as you can boot from it
to repair the system on your hard disk if that ever becomes necessary.

WARNING: You should completely back up all of your hard disks before
  proceeding. The installation procedure can completely and irreversibly
  erase them! If you haven't made backups yet, remove the rescue CD from
  the drive and press L1-A to get back to the OpenBoot prompt.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent permitted
by applicable law.

[ ENTER - Boot install ]   [ Type "expert" - Boot into expert mode ]
                           [ Type "rescue" - Boot into rescue mode ]
boot: expert
Allocated 64 Megs of memory at 0x40000000 for kernel
Loaded kernel version 4.12.6
Loading initial ramdisk (13716910 bytes at 0x204000000 phys, 0x40C00000 virt)...
[    0.000000] PROMLIB: Sun IEEE Boot Prom 'OBP 3.18.1 2006/01/23 17:06'
[    0.000000] PROMLIB: Root node compatible: sun4us
[ 0.000000] Linux version 4.12.0-1-sparc64 (debian-kernel@lists.debian.org) (gcc version 6.4.0 20170805 (Debian 6.4.0-3) ) #1 Debian 4.12.6-1 (2017-08-12)
[    0.000000] bootconsole [earlyprom0] enabled
[    0.000000] ARCH: SUN4U
[    0.000000] Ethernet address: 00:0b:5d:11:22:33
[    0.000000] MM: PAGE_OFFSET is 0xfffff80000000000 (max_phys_bits == 40)
[    0.000000] MM: VMALLOC [0x0000000100000000 --> 0x0000060000000000]
[    0.000000] MM: VMEMMAP [0x0000060000000000 --> 0x00000c0000000000]
[    0.000000] Kernel: Using 3 locked TLB entries for main kernel image.
[    0.000000] Remapping the kernel...
[    0.000000] done.
RED State Exception ( CPU#0 )
Resetting ...

Sep 06 07:02:15 CET 2017 XSCF:I::[02030100] Start reset sequence
Sep 06 07:02:15 CET 2017 XSCF:I::[02030200] Reset released...

Sep 06 06:02:18 GMT 2017 PowerOn SelfTest start
POST:Testing Flash/SRAM
POST:Testing SC
POST:Testing Timer1
POST:Testing Tick
POST:Testing MMU
POST:Testing CPU Type
POST:Memory Probe
POST:Testing Memory
POST:Testing Softint
POST:Testing U2P
POST:Testing Slave Device
POST:Testing Master Device
POST:System Configure
screen not found.
keyboard not found.
Keyboard not present.  Using ttya for input and output.

Fujitsu Siemens PRIMEPOWER250 2x SPARC64 V, No Keyboard
OpenBoot 3.18.1-1, 8192 MB memory installed
Ethernet address 0:b:5d:11:22:33, Host ID: 80112233.
XSCF Version: 4.12.1

{0} ok


Reply to: