[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Ultra-Sparc IIi, debian 6.0.3 - cant get picture from webcam logitech c170



On Sat, Jan 14, 2012 at 10:40:51AM +0100, Josip Rodin scribbled:
> On Wed, Jan 11, 2012 at 04:41:48PM +0300, Arkhipenka Stanislau wrote:
> > Hi, debian-sparc. Im trying to connect logitech c170 to server. It 
> > successfully mounted to /dev/video0, but i cant get picture. I tried to get 
> > picture with fswebcam, and got message to syslog:
> > 
> > Jan 11 15:55:26 SunFire kernel: [1512592.827475] compat_ioctl32: unknown ioctl 
> > 'V', dir=6, #26 (0xc050561a)
> > Jan 11 15:55:26 SunFire kernel: [1512592.919494] ioctl32(fswebcam:21335): 
> > Unknown cmd fd(3) cmd(c050561a){t:'V';sz:80} arg(ffa954f8) on /dev/video0
> > 
> > Also i tried applications: webcam and zoneminder. It dont work too. I tried 
> > this webcam on debian amd64 and i386 and it works fine. 
> 
> This sounds like a sparc-specific problem only insofar as the Debian sparc
> port has a 32-bit userland and a 64-bit kernel, unlike the amd64 and i386
> ports.

IIRC if you install i386 Debian on amd64 hardware, you end up
with a 64-bit kernel and 32-bit userland. I may still have one
such system, but I'd have to check when I get home; I may have
done a full amd64 install over it. Either way, I don't have a
logitech webcam, but I don't think 32-bit userland on 64-bit
kernel is all that uncommon. I know I've had a i386 chroot on an
amd64 kernel at least.

Arkhipenka: When you tried on i386 what kernel did you have?

Ivan


Reply to: