[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Ultra-Sparc IIi, debian 6.0.3 - cant get picture from webcam logitech c170

Arkhipenka Stanislau wrote:
Hi, debian-sparc. Im trying to connect logitech c170 to server. It successfully mounted to /dev/video0, but i cant get picture. I tried to get picture with fswebcam, and got message to syslog:
Also i tried applications: webcam and zoneminder. It dont work too. I tried this webcam on debian amd64 and i386 and it works fine. I have v4l on my sustem:

Frankly, I've found webcams to be very patchy on most systems, irrespective of processor. Working from memory, I found mplayer to be half-competent at exercising a v4l device, noting the workaround described at http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=542214

In practice, the only app I even half-trust is a much-hacked version of the Blundel/Forrest v4lgrab. There are far too many pitfalls based on which version of v4l a device supports, which version of v4l an app expects, pixel format including RGB vs BGR and so on. Not to mention the limited brightness etc. that most cheap cameras can accommodate.

Mark Morgan Lloyd
markMLl .AT. telemetry.co .DOT. uk

[Opinions above are the author's, not those of his employers or colleagues]

Reply to: