[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#500358: Fix found

Jordan Bettis pisze:
> Hi. I just wanted to weigh in and say that I've tried Max's fix on my
> Ultra 5 and I can confirm that it works with the X server from lenny.
> Before trying Max's kernel patch I also verified that X.org is
> *broken* and unusable using the default kernel. This is true of the
> X.org server included in Lenny as well as the 1.5.3 server in
> experimental.
> Looking at the patch it's clear that the original intention of the
> kernel change was to clean out some seemingly crufty and dodgy old
> code, but seeing that
> 1) the change is localized to SPARC machines;
> 2) it renders X.org unusable with Ultra 5s, and highly probably Ultra
> 10s as they're virtually the same, as well as an unknown set of other
> machines;
> 3) Ultra 5s and Ultra 10s seem to remain the most popular SPARC
> machines for the desktop (and therefore the set of SPARC machines
> likely to have X.org installed)
> it doesn't seem reasonable to release stable Debian system with this
> problem in it on the academic grounds that "it's X.org's fault." 
> This is a serious problem with Debian on SPARC. Assuming that Debian
> really cares about SPARC, (particularly on the desktop) and I think
> the project should do what needs to be done to make sure that this bug
> doesn't make it into the released version of Lenny.
> Someone mentioned not wanting to build their own kernel so I uploaded
> the one I built to my web server. I tried to build it from the source
> of linux-image-2.6.26, so that it would be identical to the Debian
> kernel -- with the patch applied -- but I ran into problems running
> dpkg-buildpackage. So instead I went with the usual
> linux-source/make-kpkg route. 
> I enabled just about everything though so it should be pretty similar
> to a Debian kernel with respect to features. It is also built using
> initrd.
> <http://hafd.org/~jordanb/linux-image-2.6.26murat-custom_murat001_sparc.deb>
> Sorry about the name. I got a bit carried away.

I have similar problem on Blade 150. But I just used kernel 2.6.24 and
X.org works.

## Przemysław Kulczycki <<>> Azrael Nightwalker ##
# jabber: azrael[na]jabster.pl | tlen: azrael29a #
### www: http://reksio.ftj.agh.edu.pl/~azrael/ ###

Reply to: