[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Netboot E250 -- tftp problem (SOLVED)

Hi, everybody!

I have successfully installed debian etch on the E250! The solution is simple: pull out all the memory modules, wipe dusts off the slots and modules, then plug back in, netboot works.


1. Stappers early said that it maybe a memory problem, but back then when I followed his instructions, all went OK. But today I found it was not OK with "Fast Data Access MMU Miss", I filled and dumped again, and got OK again. So I thought maybe the modules did not touch well with the slots, and actually they did.

2. There was a lot of UDP checksum errors in TFTP packets annoying us badly. But they are really irrelevant: before I got to the solution, I replaced Realtek 8139 NIC with Intel e100, and the checksum errors had all gone, but it still get stuck with packet. After I succeeded with Intel e100, I changed back to Realtek 8139, the checksum errors emerged again, but E250 still netbooted.
I don't know whether it is a bug with wireshark or a flaw with Realtek 8139.

These irrelevant checksum errors drew our attention to networking, which made this problem seem extremly strange.

3. I appreciate all of you on the list kindly helping me. These are my first posts to debian-sparc, and it feels great! Stappers is so genial that I learned a lot through the emails and got to notice many mistakes I had made.

4. This E250 is my first non-x86 mechine, Openboot and Forth is also new to me (altough I have a OLPC, which uses Openboot as well). Sparc is really a different world, it gives me special experience! Actually our E250 has been down lying in our lab for years and no one has touched it, now it is up and running happily serving his x86 fellows around, that is really COOOOOOL! By the way, I like the beeps of the E250 box, I have heard too many beeps of IBM PC :P

It is Chinese New Year on Feb 7. Happy Chinese New Year to you (and myself:) !

Xu, Benda

Fundamental Science of Mathematics and Physics,
Tsinghua University, Beijing, P.R.China


Reply to: