[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: SunBlade2000 illegal instruction right after SILO

Dear Bernd,

thank you for your immediate reply. I wanted to crosscheck with my colleague 

On Saturday 03 November 2007 23:25:36 Bernd Zeimetz wrote:

> > we successfully netboot a Blade 2000 donated to us with Etch's netboot
> > install disk. We went through the Sparc install instructions and,
> > switching to the second console at the right times (the installer could
> > be more helpful here), also installed firmware-qlogic which allowed us to
> > continue with the installation. We have a complete lvm-based file system
> > on our disk. The update-initramfs was executed.
> Just because it may help with a different bug: Does the Blade run with
> one or two CPUs?

We do not really know, I must admit. cat /proc/cpuinfo of the installer lists 
only one, we presumed two, though there was no clear indication of that in 
the boot messages, it may hence well be only one.

> > After a reboot the SILO is found. Return is pressed and immediately an
> > illegal instruction is raised.
> Which Kernel are you trying to boot? I run into such things while trying
> to boot a SMP Kernel on non-SMP machines and the other way round. Also
> 2.6.18 seems to have issues with US III CPUs in general.

It was 2.6.18. Though it booted fine with the installer.

We tried both the SMP kernel and the non-SMP kernel - same effect.

> Try to boot with -p as option, that'll probably give more output.

I read this several times on google but do not know how to do that at the 
moment. You probably mean -p as a parameter to the boot call in the boot PROM 
mode. I'll give it a try.

> > There is no ready Debian sparc machine at our disposal, which means that
> > we cannot construct an image to boot ourselves, right?
> As the installer boots the installed Kernel should boot on the machine,
> too, as it is the same Kernel version as the one from the installer
> usually. Please note that you have to update your initrd if you've
> installed the firmware package after the Kernel. But this doesn't result in
> the
> mentioned illegal instruction.
We have done that.

My hunch is that the issue is with SILO, not with the Kernel. It is happening 
right after pressing return at the SILO prompt. Others apparently experienced 
difficulties with SILO, too 

Is there something I could netboot easily to circumvent SILO issues and that 
allows me to use our current root? Something that comes with the 
firmware-qlogic package already?



Attachment: signature.asc
Description: This is a digitally signed message part.

Reply to: