[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Problem with linux on SunFire 280R

I have tried to install debian and gentoo on this SunFire 280r but without
success. In google I found that it is possible to install debian (the first
message below) on 280r. I tried many installation CDs and tftp boot images
but there is no support for hard disks with fiber chanel. With gentoo i've
stuck like in the second message below.
I would prefer debian...
So maybe, someone could give me some tips about initramfs tools any help is


"Hello world,

I am trying to get an "old" Sun Fire 280R running with Debian. After one
week trial and error I got the base system
installed from BusinessCard-ISO using Etch beta3 (all others did not boot).
Got the FC-AL-HDDs running with
initramfstools loading qlogicfc using the original kernel (which did not
recognize the controller on his own). Now
I am trying to build a kernel (source 2.6.16) with integrated FC-AL-Support
and some other features to maximize
stability and minimize problems. At the moment I am really stuck with the
graphics console - I can not get a local
console running after loading the kernel from silo. There's a PGX64
(ATI-based) graphics card in this server. I am
used to Debian on x86- and powerpc-architecture, but I am new to sparc.

If anyone is using such a workgroup server with local console, it would be
nice to get a running kernel config to
have a usable base for further optimizations.


Matthias Petz"

"I managed to install gentoo 2006.1 from Universal CD without connection to
the network. I choose kernel 2.6.17 for compilation. Everything seems to be
ok according to the manual for Sparc computers but after booting I got
message "Can't open boot device" from OpenBoot PROM. I am not experienced
with Sun architectures so my question is if the mistake is with linux
(kernel or SILO) or rather with OpenBoot PROM? 
I have OpenBoot 4.10.11. After running SILO silo.conf seems to be OK. I've
tried commands like "boot disk", "boot disk1" and so on but without success.
My kernel after compilation is big above 4MB but there is in manual that it
shouldn't be a problem with kernel version > 2.6.3 
Thanks in advance for any suggestions 
Gentoo is my last hope to have Open Source software on this machine....  The
only linux system which recognized the fiber chanel disks."

Reply to: