[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

RE: Sun Fire 280R - kernel config for PGX64

>-----Original Message-----
>From: Jurij Smakov [mailto:jurij@wooyd.org] 
>Sent: Tuesday, September 12, 2006 5:06 AM
>To: Viper446
>Cc: debian-sparc@lists.debian.org
>Subject: Re: Sun Fire 280R - kernel config for PGX64
>On Mon, 11 Sep 2006, Viper446 wrote:
>> Hello world,
>> I am trying to get an "old" Sun Fire 280R running with Debian. After one
>> week trial and error I got the base system
>> installed from BusinessCard-ISO using Etch beta3 (all others did not
>> Got the FC-AL-HDDs running with
>> initramfstools loading qlogicfc using the original kernel (which did not
>> recognize the controller on his own). Now
>> I am trying to build a kernel (source 2.6.16) with integrated
>> and some other features to maximize
>> stability and minimize problems.
>Not sure about those issues, but beware that starting with 2.6.17 
>qlogicfc module is phased out, presumably its functionality is 
>provided by 
>the qla2xxx module. If you have a chance, it would be great if 
>you could 
>try a latest installer daily, available from
>and let us know whether the qla2xxx module actually works and 
>hardware is 
>properly detected.

Tried the daily build on Tuesday, could not get tftpboot running - do not
know why - used it some time ago successfully. Rarpd answered and started to
transfer the file, but after two timeouts the Sun said: retrying...
Checked the latest daily etch iso - did not boot due to silo mmu problem
(older silo version like 1.4.12 booting fine).

But I've tried to compile a 2.6.17 and a 2.6.16 kernel - the qla2xxx did not
recognize the fc-al-drives. Using a 2.6.16 now with built-in qlogicfc -->
works really fine. In the etch beta3 iso I have to load the qlogicfc module
manually using modprobe during the installation.

>> At the moment I am really stuck with the
>> graphics console - I can not get a local
>> console running after loading the kernel from silo. There's a PGX64
>> (ATI-based) graphics card in this server.
>What problems exactly are you facing? Did xorg automatically 
>generate the 
>config on your install? What driver did it use? If it's an 
>ATI, the driver 
>most probably has to be 'ati'. Please have a look at the page
>http://wiki.debian.org/XorgOnSparc for some working xorg 
>config examples.

I am not able to get a framebuffer console running, do not really need X. I
am using the console now without any enabled framebuffer options in .config
running via prom (looks like openboot console, and it is really slow and
ugly like openboot). I tried different .config options, but without success.

>Best regards,
>Jurij Smakov                                        jurij@wooyd.org
>Key: http://www.wooyd.org/pgpkey/                   KeyID: C99E03CC
>To UNSUBSCRIBE, email to debian-sparc-REQUEST@lists.debian.org
>with a subject of "unsubscribe". Trouble? Contact 

Reply to: