[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: RFC: xorg configuration generation on sparc

now that I have X loaded, the keyboard and the mouse DO work, but the keyboard layout must be incorrect, because the keys I press type differen't letters.

what should they keyboard type and layout be in the xorg.conf file?

this is what I have now:

Section "InputDevice"
        Identifier      "Generic Keyboard"
        Driver          "keyboard"
        Option          "CoreKeyboard"
        Option          "XkbRules"      "sun"
        Option          "XkbModel"      "type5"
        Option          "XkbLayout"     "us"

Jeff M.

On 7/14/06, Jeffrey Maples <grapnell@gmail.com> wrote:
fixed it by loading the cfb and cfb32 modules

On 7/14/06, Jeffrey Maples < grapnell@gmail.com> wrote:
Ok, I have upgraded to unstable, and now the driver is available, but, i still get no screens found error. I have looked in the "/usr/lib/xorg/modules/drivers/" directory, and "sunffb_drv.so" does exists, so I know/assume I have the correct packages installed. Perhaps something else is my problem. maybe a mis-match kernel or something? I really don't know...
Any more help would be great.

here is my output, starting with loadmodule sunffb:

(II) LoadModule: "sunffb"
(II) Loading /usr/lib/xorg/modules/drivers/sunffb_drv.so
dlopen: /usr/lib/xorg/modules/drivers/sunffb_drv.so: undefined symbol: cfbCopyPlane8to1
(EE) Failed to load /usr/lib/xorg/modules/drivers/sunffb_drv.so
(II) UnloadModule: "sunffb"
(EE) Failed to load module "sunffb" (loader failed, 7)
(II) LoadModule: "keyboard"
(II) Loading /usr/lib/xorg/modules/input/keyboard_drv.so
(II) Module keyboard: vendor="X.Org Foundation"
        compiled for 7.0.0, module version = 1.0.0
        Module class: X.Org XInput Driver
        ABI class: X.Org XInput driver, version 0.5
(II) LoadModule: "mouse"
(II) Loading /usr/lib/xorg/modules/input/mouse_drv.so
(II) Module mouse: vendor="X.Org Foundation"
        compiled for 7.0.0, module version = 1.0.4
        Module class: X.Org XInput Driver
        ABI class: X.Org XInput driver, version 0.5
(EE) No drivers available.

Fatal server error:
no screens found


On 7/14/06, Frans Pop < aragorn@tiscali.nl> wrote:
On Friday 14 July 2006 19:54, Jeffrey Maples wrote:
> I retract my second post.  The use of the sunffb driver worked on
> woody, but when I did an apt-get dist-upgrade to testing, the sunffb
> driver is non-existent.  Is there another driver I should use in the
> testing release? I am really at a loss now, and really don't want to
> downgrade back to woody.

The drivers are currently probably only in unstable as they were only
recently uploaded for the first time. But I think you should be able to
download them from unstable and install them (using dpkg -i) on testing.

Reply to: