[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

MySQL issues on sunfire V240


I recently set up a debian etch LAMP server on a sunfire v240 and have now
started to try to use it for things like mediawiki, wordpress and moodle. I
have found though that MySQL does not appear to be working correctly. For
example, if I run WordPress's configuration script, it appears to set up
correctly and creates all the tables in the database, but when you then try
to visit the site you get the following error:

WordPress database error: [Can't create/write to file '/tmp/#sql_c6a_0.MYI'
(Errcode: 13)]

 SELECT DISTINCT * FROM wp_posts WHERE 1=1 AND post_date_gmt <= '2006-06-26
10:54:59' AND (post_status = "publish") AND post_status != "attachment"
GROUP BY wp_posts.ID ORDER BY post_date DESC LIMIT 0, 10

I thought at first it might be a problem with the MySQL account I had
created, so as an experiment I configured Wordpress to use the MySQL root
account, but it gives the same problem.

I tried setting up mediawiki, but it complains "A database error has
occurred Query: SHOW STATUS LIKE 'Thread%' Function: Error: 2006 MySQL
server has gone away (localhost) Backtrace: GlobalFunctions.php line 602
calls wfbacktrace() Database.php line 473 calls wfdebugdiebacktrace()
Database.php line 419 calls databasemysql::reportqueryerror() Database.php
line 1647 calls databasemysql::query() LoadBalancer.php line 202 calls
databasemysql::getstatus() LoadBalancer.php line 355 calls
loadbalancer::getreaderindex() DatabaseFunctions.php line 52 calls
loadbalancer::getconnection() User.php line 150 calls wfgetdb() User.php
line 75 calls user::idfromname() index.php line 707 calls

All of the MySQL logs in /var/logs are completely blank as well, which isn't
helpful. Im a little frustrated as this stuff all works fine on our x86
servers, so i'm wondering if anyone knows of issues with MySQL 5 running on
sunfire V240 machines or has any suggestions to resolve this problem?

View this message in context: http://www.nabble.com/MySQL-issues-on-sunfire-V240-t1848493.html#a5045674
Sent from the debian-sparc forum at Nabble.com.

Reply to: