[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

RE: sparc32 problems with libc6 and 2.4 kernel

Thank-you for this information. I have finally had a chance to remove
gentoo and give this a try.


I verified the installation of aptitude (woody version)
I verified that no packages were broken, unconfigured or pending in dpkg
I have altered my sources.list with the suggested repository 
I have installed modutils (successful, but: **Unresolved Symbols in
Cannot install initrd-tools as it is expecting cramfsprogs (>= 1.1-4)
Cannot install cramfsprogs as it is expecting zlib1g (>= 1:1.1.4)
zlib1g has the libc6 issue again.....

I will continue to review the documentation, and attempt to understand
where I am going wrong.


-----Original Message-----
From: Jurij Smakov [mailto:jurij@wooyd.org] 
Sent: Wednesday, June 07, 2006 9:25 PM
To: Shaun Prince
Cc: Petr.Salinger@seznam.cz; debian-sparc@lists.debian.org
Subject: RE: sparc32 problems with libc6 and 2.4 kernel

On Tue, 6 Jun 2006, Shaun Prince wrote:

> Thanks for the advice. I have determined that the problem was initrd.
> Using vanilla-sources, I have compiled a initrd-free 2.4.32-r4 kernel
> using a gentoo tftpboot image (4hrs compile time, 2MB unzipped). This
> kernel works excellent with debian/unstable and runs really nice on my
> Quad CPUs.
> I have tried to start with woody and slowly 'evolve' my distro with no
> success. Woody -> sarge, sid or etch; sarge (by itself); ect.. process
> of elimination =) I have tried all of the available tftpboot and
> boot images found at http.us.debian.org looking for a solution.

This is a known issue. Because of the libc and kernel circular
we had to formulate a special upgrade procedure for sparc. It is 
documented in the Sarge release notes for sparc:


Best regards,

Jurij Smakov                                        jurij@wooyd.org
Key: http://www.wooyd.org/pgpkey/                   KeyID: C99E03CC

Reply to: