[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

RE: sparc32 problems with libc6 and 2.4 kernel

Thanks for the advice. I have determined that the problem was initrd.
Using vanilla-sources, I have compiled a initrd-free 2.4.32-r4 kernel
using a gentoo tftpboot image (4hrs compile time, 2MB unzipped). This
kernel works excellent with debian/unstable and runs really nice on my
Quad CPUs.

I have tried to start with woody and slowly 'evolve' my distro with no
success. Woody -> sarge, sid or etch; sarge (by itself); ect.. process
of elimination =) I have tried all of the available tftpboot and floppy
boot images found at http.us.debian.org looking for a solution.

This initrd issue also exists with many other distributions that offer
binary kernels, so this is not necessarily a debian issue. Even after I
compile the initrd.img, my hypersparcs give me spinlocks with "cramfs:
bad magic" and so on, and the boot does not complete.

NetBSD 2.0, 2.1 and 3.0 also gave me grief. After installing, they would
freeze up at a certain point, but I did not try to manually circumvent
those issues.

There needs to be manual tweaking in order to get any version of debian
and it's installer, pre-dating June 1st, 2006. If there is interest, I
would be more than happy to further document my testing.


-----Original Message-----
From: Petr Salinger [mailto:Petr.Salinger@seznam.cz] 
Sent: Monday, June 05, 2006 2:36 AM
To: sys.admin@shaw.ca
Subject: Re: sparc32 problems with libc6 and 2.4 kernel


only hint:
You should try to upgrade to sarge version first, not directly to sid


Reply to: