[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: USB on Ultra 10

Hi Vincent and all,

thanks for your answers!

"VV" == Vincent Vandeweijer writes:

 VV> Hi, Worked without any problems on my U10. That includes USB2.0
 VV> :) Haven't tried firewire yet but I'm soon gonna. Modules load
 VV> without problem.

 VV> <snip> vincent@ra:~$ uname -a Linux ra 2.6.12-1-sparc64 #1 Tue
 VV> Sep 27 23:45:57 UTC 2005 sparc64 GNU/Linux

 VV> I'm just using some dirt cheap USB controler. Don't even remember
 VV> the brand.  First one I tried (a combined USB2.0 Firewire card)
 VV> failed to be seen on the pci bus completely. Worked in a (normal)
 VV> PC though. With the one I'm using now I was just lucky i
 VV> guess... My advice: try another one?

Thanks! You know, that worked! :) i've installed the Gembird USB
controller (on the Ali chipset), and it now works great! (including USB 2.0).

$ uname -a
Linux video 2.4.27-2-sparc64 #1 Sun Apr 3 05:21:36 UTC 2005 sparc64 GNU/Linux
$ cat /proc/cpuinfo
cpu             : TI UltraSparc IIi (Sabre)
fpu             : UltraSparc IIi integrated FPU
promlib         : Version 3 Revision 31
prom            : 3.31.0
type            : sun4u
ncpus probed    : 1
ncpus active    : 1
Cpu0Bogo        : 599.65
Cpu0ClkTck      : 0000000011e1a300
MMU Type        : Spitfire
$ lspci
0000:00:00.0 Host bridge: Sun Microsystems Computer Corp. Ultra IIi
0000:00:01.0 PCI bridge: Sun Microsystems Computer Corp. Simba Advanced PCI Bridge (rev 11)
0000:00:01.1 PCI bridge: Sun Microsystems Computer Corp. Simba Advanced PCI Bridge (rev 11)
0000:01:01.0 Bridge: Sun Microsystems Computer Corp. EBUS (rev 01)
0000:01:01.1 Ethernet controller: Sun Microsystems Computer Corp. Happy Meal (rev 01)
0000:01:02.0 VGA compatible controller: ATI Technologies Inc 3D Rage I/II 215GT [Mach64 GT] (rev 9a)
0000:01:03.0 IDE interface: Silicon Image, Inc. (formerly CMD Technology Inc) PCI0646 (rev 03)
0000:02:02.0 USB Controller: ALi Corporation USB 1.1 Controller (rev 03)
0000:02:02.1 USB Controller: ALi Corporation USB 1.1 Controller (rev 03)
0000:02:02.3 USB Controller: ALi Corporation USB 2.0 Controller (rev 01)

Vincent, i see that you're using linux 2.6.12 on similar hardware
(your video card is slightly different, though).  My attempts to use
2.6.* kernels on this Ultra 10 failed: i had two kinds of problems:

1) upon boot, when SILO loads the kernel, it fails to setup the
   framebuffer, and i see some slooow messages on SUN text console,
   and when the first screen fills up, it doesn't show anything more
   (until X is being loaded)

2) when it switches to X, the screen blanks and nothing shows up.  i
   asked about this previously, and Dave Miller said that there's some
   bug in X code which expects to find some obsolete paths in
   /proc/pci/... and to solve that one needs to recompile X from
   latest sources.

so my next question is (since i very much want to switch to 2.6
kernel): have you faced any of the abouve problems? and what did you
do to solve them?


Reply to: