[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: problems using a printer at my ultra5

Dr. Zimmermann wrote:


Id'd like to connect a printer (via parallel or usb connectors) to my ultra5.

Both connections (parallel and usb) lead to problems  ...

After modprobing parport_pc the printer is successfully  autoprobed
(/proc/sys/dev/parport/parport0/autoprobe shows the correct printer type)
The printer can be installed in cups without errors ... If I try to use
it there were messages at the console and in the syslog:
lp0: ECP mode
... but nothing is received by the printer ('data' light stays dark)

As stated in the kernel documentation I switched off the FIFO option
and try to:
insmod parport_pc irq=none

still no data arrives via parallel port ...
The parallel port on the ultra5 seems to be a black whole !

Trying the USB-port (cat ... > /dev/usb/lp0) transmits some data to the printer (i.e. 'data' light is blinking) - due to incomplete ioctl calls on sparc64 linux I receive
errors when I try printing using cups.
(see also http://lists.debian.org/debian-sparc/2004/11/msg00193.html)

I've used severel 2.6 kernels for testing ...
Any help ?


The parallel printer port driver has not worked since maybe 2.2.x, this is a known problem. I use a network connected printer (HP2250CN) here OK.
Sorry - I have not tested USB so I cannot help there.

First make sure that you have not installed lprng, if you install lprng and cups then neither will work. You will need to remove both and then re-install cups.

Reply to: