[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

RE: Debian on Sparc 4 - woody to sarge

Hi Jurij et all,

Firstly, thanks for the help, it's appreciated.

This is making more sense now ... finally ... sort of :)  I have not as
yet ever tried to upgrade a kernel and perhaps it would have been more
straight forward if the releases had not just changed.

I do not have a /boot partition.  I have created a / partition on sda1
which is where my /boot directory is.  Perhaps it would have been
simpler if I had.

I have vmlinux in / (root) which is symlinked to vmlinuz-2.2.20-sun4cdm
in the /boot directory: -

lrwxrwxrwx    1 root     root           27 Apr  2 16:52 vmlinuz ->

My silo.conf reads: -


So, it seems (as I can boot with no problems from the current kernel and
silo.conf) that once I have gone through the downloading of packages and
editing the /etc/apt/sources.list again, the silo.conf should be edited
to read: -




I should then remove the existing symlink and create a new one called
vmlinuz.old pointing to my 2.2.20 kernel and create a new symlink called
vmlinuz pointing to the new 2.4.27 kernel

Any issues on rebooting the new kernel would allow me to boot using the
following: -

linux image=1/boot/vmlinux-2.4.27-2-sparc32
initrd=1/boot/initrd.img-2.4.27-2-sparc32 root=/dev/sda1

And failing that to be able to use the old kernel by doing: -

linux image=1/boot/vmlinux-2.2.20-sun4cdm
initrd=1/boot/initrd.img-2.2.20-sun4cdm root=/dev/sda1

Do these need to be proceeded with the command 'boot'?

I am not very familiar with where initrd installs into but looking at
what you have written it seems like it also installs into the /boot

Does that all sound ok?

I have used apt-get to download and install some of the packages, to
gain some headway.  The following may be of interest: -

apt-get install modutils


Architecture-specific modutils configuration not found, using defaults
depmod: *** Unresolved symbols in /lib/modules/2.2.20/hfs.o

apt-get install initrd-tools


Setting up ash (0.3.8-37) ...
scsi0: MEDIUM ERROR on channel 0, id 3, lun 0, CDB: 0x03 00 00 00 10 00
Info fld=0x1e7ec2, Current sd08:07: sns = f0 3
ASC=11 ASCQ=43
Raw sense data:0xf0 0x00 0x03 0x00 0x1e 0x7e 0xc2 0x0c 0x0d 0x32 0x04
0x2a 0x11 0x15 0x80
scsidisk I/O error: dev 08:07, sector 590354

Setting up cramfsprogs (1.1-6.woody1) ...

Setting up stat (3.3-2) ...

Setting up initrd-tools (0.1.79-0.woody1) ...

Seems the errors setting up ash is related to /dev/sda7 which is my /usr
partition.  I have no idea if any of the errors above will affect the
kernel upgrade or not.

I have also used wget to download the kernel package but have not used
dpkg to install it as yet: -


I have not edited the silo.conf or symlinks just yet, I thought it wiser
to see if there any tips from this message.  I remember that when the
kernel package is installed that there is a question about symlinking
but cannot quite remember it, something about doing it from scratch.

Cheers for your time all,


-----Original Message-----
From: Jurij Smakov [mailto:jurij@wooyd.org] 
Sent: 01 July 2005 01:39
To: Steve Lewis
Cc: 'Debian Sparc'
Subject: RE: Debian on Sparc 4 - woody to sarge

On Thu, 30 Jun 2005, Steve Lewis wrote:

> I have since tried to upgrade my kernel to the 
> kernel-image-2.4.27-2-sparc32_2.4.27-2_sparc.deb package but had a 
> kernel panic, unable to mount root fs error on the reboot.  I think 
> this could be a silo.conf error.  I did add the initrd line to 
> silo.conf but I didn't include a root=/dev/sda1 line.  I had a look 
> around for a decent (full and complete) example of a silo.conf file 
> but couldn't find one on the net.

The manual page accessible with 'man silo.conf' command contains
documentation. Here's my working silo.conf:




Note that in my configuration /boot is a separate partition (/dev/hda1),

which is also default (set by partition=1), so paths to the files are 
given relative to that partition. So setting image=/vmlinuz when the 
default partition is 1 will actually try to load file vmlinuz from the 
root of partition 1, which translates to /boot/vmlinuz.

Also, if your silo.conf is broken, you still should be able to boot by 
typing something like this at the boot prompt:

linux image=1/boot/vmlinux-2.4.27-2-sparc32
initrd=1/boot/initrd.img-2.4.27-2-sparc32 root=/dev/sda1

If you are still having trouble, post your silo.conf and we should be
to figure it out.

Best regards,

Jurij Smakov                                        jurij@wooyd.org
Key: http://www.wooyd.org/pgpkey/                   KeyID: C99E03CC

To UNSUBSCRIBE, email to debian-sparc-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact

Reply to: