[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Ultra 5, Debian and an IDE-controller


Just before a few days I've got a Promise Ultra66 IDE-controller (pdc202xx_old) and I thought it would be quite nice to use it in my U5 for my HDD. The next idea was that I could use a CF-IDE-adapter and a 16 Mb CF-card to put /boot on it and connect it to the onboard-controller (cmd640) in order to install silo into the MBR of the card and to load Linux off it.

I connected all these components and OBP recognizes all of them (The pci-contoller is recognized as unknown device, because OBP lacks support for it.). So far, so good. ;) I've downloaded the Sarge businesscard-ISO (daily build) and tried to install it. After booting just the CF-card was shown as recognized hdd, so I went into a console and loaded the modules ide-disk and pdc202xx_old. At once a kernel oops appears and the pdc202xx_old modules doesn't initialized properly.

The next idea was to grab the Woody rc4-ISO. The pci-controller is recognized and correctly initialized, but the onboard-chipset isn't. I was even able to install the base system on the HDD connected through the pci-controller. The error-message "too many IDE interfaces, no room in table" appears. I've tried to pass "ide0=cmd640" as an argument to the kernel, but this doesn't help.

While googling around with the error-message of the cmd640, I've read that this error appears if there are no device nodes (/dev/hdX) left, but the Woody installer offers more than enough.

I have no further ideas what I could do. But perhaps someone of you? ;)

Thanks in advance.

Best regards,

Reply to: