[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Solved! Was Re: [newbie] Installation problems

Hi all,

Circumvented my problem by wimping out - found someone at work running Debian on an assortment of Ultra5s who had a spare SS20 and got him to install it for me ;)

My first boot attempt from it failed as he'd made the boot partition >1GB (need to burn myself a new PROM) but feeding the boot: prompt with '1/vmlinuz root=/dev/sda2/' started the boot process fine. It then had a kernel panic with assorted warnings so I rebooted and added '-single' to the commandline, which led to my first successful boot :-) On a reboot the config I tried first worked as well, so the problem fixed itself. Brilliant, I have a working Debian box :-)

Now all that's left to do is figure out how to setup X properly and I'll be away!

Many thanks to all for the help attempts.


From: "Nick [Stone]" <the_stony_1@hotmail.com>
To: the_stony_1@hotmail.com
Subject: Re: [newbie] Installation problems
Date: Thu, 22 Jul 2004 23:08:12 +0000

Woo! I finally got the kernel mounted up (didn't realise you had to mount root where it's located, not where you *want* it to be installed. Not obvious enough ;-) ) using

boot: linux root=/dev/scd0/

Now it finds the hdd partitions, then gets to:

Warning: unable to open an initial console
Kernel panic: No init found. Try passing init= option to kernel.
Press L1-A to return to the boot prom

With a quick search I see various things about not having a /initrd dir, or /dev/ being unpopulated, as well as lots of info on how to fix it if you already have a mostly-working system :-( This happens with several different boot CDs - I presume they aren't all built incorrectly, so is there some incredibly-obvious way of doing this off the boot: commandline that I'm missing, or do I have to burn yet more CDs?




Hi again everybody,

Been fiddling with this a bit more last night. Giving 'linux root=/dev/sda1' at the SILO boot: prompt failed claiming the partition didn't exist. sda2 and sda3 were both detected by the loader but they caused 'bad magic number' claims and more kernel panicing.

One format in the single-user Solaris shell later (ie: much later) to restore the sun disklabels (I didn't realise 'label' in Solaris format would do this much faster...) and I'm getting pretty much the same issues, although the kernel now sees sda1 and sda7 as valid partitions

So far what I think is happening is, the kernel's not finding anywhere to put root which is acceptable to it - the disk's totally blank which might explain that, but even if I overwrite its attempt to netboot by specifying 'root=...' then it still doesn't work. I had a flash of inspiration and used 'root=/dev/ram' (as my RAMdisks are being configured ok) but that looked like it was just being ignored as the installer just tried to netboot anyway.

I'm pretty certain it'll all resolve itself if I can keep the kernel happy long enough to actually start the installation since it'll then have somewhere to put root once it's repartitioned the disk, but I can't see any way of doing that now, having exhausted all my inspiration :-(

Anyone? All suggestions appreciated :-)



It's fast, it's easy and it's free. Get MSN Messenger today! http://www.msn.co.uk/messenger

To UNSUBSCRIBE, email to debian-sparc-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Use MSN Messenger to send music and pics to your friends http://www.msn.co.uk/messenger

Reply to: