[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]



I have been running Debian Unstable on my Ultra 2 (2x300Mhz, 768MB RAM)
for quite a few months now without issue.

Last night, I updated my system using apt-get as I do every couple of
days or so.  It seemed to update quite a few key things such as gcc
which all seemed to update successfully.

I normally leave the machine on 24/7 but shut it down last night for the
first time in maybe a couple of weeks.

When I tried to boot the machine this morning, the system only wanted to
mount the root filesystem read-only and the booting process failed when
the machine got to the "init 3" stage.

I tried scrolling back to see if I could work out what was happening
earlier in the boot process but the only thing I could see was something
along the lines of:

"mount: you must specify a filesystem type" around the time when it was
mounting the root filesystems.

I also noticed at the prom boot prompt, it said:

Allocating 8MB memory at 0x40000000 for kernel

quickly followed by another message:

Kernel doesn't support loading to high memory, relocating...done.

The kernel that it is trying to boot into is a 2.4.23  I am not sure how
to view my silo.conf file from the prom as I was going to try another
kernel image to see if I could boot using that (I can't remember what
alias names I have given older kernels on there!)

I am really stumped here and any pointers would be greatly appreciated.

Currently on Silo version 1.4.4.



Reply to: