[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: UFS-write problem

On 07.12.2003, at 13:02, arvind@acarlab.com wrote:


I have just upgraded my Sun Ultra5 to Woody_r1-ish state. Everything's working - XFree86-4.1.0woody, devfsd, ext3, enlightenment, sound, etc. Kernel has the netfilter-bridge-0.0.7 patch. Finally my Ultra5 is as good as the PCs.

My problem is - I can't write to the UFS SunOS-7 partition. The kernel has been configured with CONFIG_UFS_FS=m and CONFIG_UFS_WRITE=y. I can mount the partiton read-write and copy files from it. But when I try to write to it, ( with cp or dd ) I get a strange error message - 'cannot create regular file XXXX: read-only file system'. 'mount' shows it to be mounted rw on /sundisk; and the ufs.o module is loaded. I tried to write to it as root too - but same message.

I have been regularly reading/writing to the UFS partition with the previous Debian-potato installation before.

- Arvind R.

Hi Arvind,

I had the same problem some some days ago running Linux (2.4.23)
on a Sun Netra1.

We solved the problem with remounting the sun-ufs partition.

mount -o remount,rw <ufs-device>



Reply to: