[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: cannot find sparc64.gz

On Monday 18 August 2003 15:53, Volker Augustin (multi.art.studio) wrote:

> installation was fine and very fast on my u5/333/512 and u160 scsi, wow -
> a rocket.
> after finishing install i was asked to boot......ok, but my sun is only
> booting from ide0. i tried to add some devaliases on my boot-prompt, e.g.
> devalias scsi0 /pci@1f/... somehting like ide, but i got no results, just
> 'cannot find boot-device' from the prom.

It smells like, if your Adaptec scsi card is a standard PC card without 
special Sun PROM code in it, you can't boot from your scsi card.
Maybe you'll better install /boot and make bootable an old (and cheap) 
somewhat-like-1Gb IDE hard drive (since the internal IDE controller is 
recognized by the PROM), compile the Adaptec driver as static in your kernel 
and let all the other partitions lay on the u160 drive(s).

On the topic: Has someone succeded in recompiling a 2.4.x/2.6.x kernel on 
unstable? Tried with both with no success at all, a brief detail follows:

- 2.4.21 (Debian sources)
No luck with "make menuconfig", curses libraries being discarded as marked 
"incompatible" :(
Success with "make xconfig", kernel compiles ok, but after image decompression 
(by SILO, of course), the box hangs with a "data access exception" and I'm 
back at the "ok" prompt. Supplying the complete pathname for vmlinuz-2.4.21 
within the SILO prompt boots the new kernel, but it locks up with a kernel 
panic yelling that it can't find the root device 0:0 (the root device is on 
the IDE controller and the driver is compiled statically in the kernel, in 
fact I get correct output in kernel messages. I compile kernels since years, 
never had a problem like this. Maybe I have to mangle silo.conf but I can't 
find documentation.

- 2.6.0-test3 (kernel.org)
No luck in "make menuconfig" (same problem as 2.4.21)
No luck in "make xconfig" (output says i can't xconfig on Sparc)
No luck in "make gconfig" (same problem as 2.4.21, this time complaining about 
libglade2 being "incompatible")
Antonello Iunco <etn at libero dot it>
Cruising the Web on a (Modified) Debian-Powered Sun Ultra10

Reply to: