[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

2.4.21pre6 sun4u root partition mounting failures

With all the help I've gotten on this list, I've successfully been able
to create kernels that boot on my machine, with one caveat.

None of the 2.4.21 pre6 kernels that I've managed to compile have been
able to mount my root partition, which is at /dev/hda1

I have tried to compile the 2.4.21-pre6 kernel with the .config used for
my 2.4.20 kernel that I am currently running on. (Because for some
reason I can't recompile the 2.4.20 kernel - attempting to recompile
gives me a ide-cd compile failure).

Has anybody else seen anything like this?  Discovered a fix?

My root is a ext3 partition, and I have ext3 compiled in.  The drive
conroller show sup fine in the kernel messages during boot.  I have
tried compiling with advanced partition support on AND off, to no avail.


This is the script I am using to do my kernel compiles:
sudo rm -rf linux-2.4.20 ; \
tar jfx linux-2.4.20.tar.bz2 ; \
patch -p0 < patch-2.4.21-rc6 ; \
cd linux-2.4.20 ; \
cp ../.config . ; \
cd drivers/ ; \
mv ieee1394 ieee1394.orig ; \
mkdir ieee1394 ; \
cd ieee1394 ; \
cp ../../../ieee1394svn/* . ; \
cd ../.. ; \
make xconfig ; \
sudo make-kpkg --subarch=sun4u --arch_in_name --revision=sat1394.10 \
kernel_image ;\
cd .. ;\
rm vmlinu* ;\
sudo rm -rf /lib/modules/2.4.21-rc6 ;\
sudo dpkg -i sudo dpkg -i
kernel-image-2.4.21-rc6-sun4u_sat1394.10_sparc.deb ;\
cp /boot/vmlinuz-2.4.21-rc6 vmlinux.gz ;\
gunzip vmlinux.gz ;\
strip -R .comment -R .note vmlinux -o vmlinux.stripped ;\
gzip -9vc vmlinux.stripped > vmlinuz.boot ;\
sudo cp vmlinuz.boot /boot/vmlinuz.test

This is what my dmesg tells me on a working boot of 2.4.20

Uniform Multi-Platform E-IDE driver Revision: 6.31
ide: Assuming 33MHz system bus speed for PIO modes; override with
CMD646: IDE controller on PCI bus 01 dev 18
CMD646: chipset revision 3
CMD646: chipset revision 0x03, MultiWord DMA Force Limited
CMD646: 100% native mode on irq 4,7e0
    ide0: BM-DMA at 0x1fe02c00020-0x1fe02c00027, BIOS settings: hda:pio,
    ide1: BM-DMA at 0x1fe02c00028-0x1fe02c0002f, BIOS settings: hdc:pio,
hda: ST39120A, ATA DISK drive
ide: Assuming 33MHz system bus speed for PIO modes; override with
hdc: CRD-8322B, ATAPI CD/DVD-ROM drive
ide0 at 0x1fe02c00000-0x1fe02c00007,0x1fe02c0000a on irq 4,7e0
ide1 at 0x1fe02c00010-0x1fe02c00017,0x1fe02c0001a on irq 4,7e0 (shared
with ide0)
hda: 17803297 sectors (9115 MB) w/512KiB Cache, CHS=17662/16/63, (U)DMA
hdc: ATAPI 32X CD-ROM drive, 128kB Cache
Uniform CD-ROM driver Revision: 3.12
Partition check:
 /dev/ide/host0/bus0/target0/lun0: p1 p2 p3
Floppy drive(s): fd0 is 1.44M
FDC 0 is a National Semiconductor PC87306
sunhme.c:v2.01 26/Mar/2002 David S. Miller (davem@redhat.com)
eth0: HAPPY MEAL (PCI/CheerIO) 10/100BaseT Ethernet 08:00:20:e7:ac:fe
[drm] Initialized ffb 0.0.1 20000517 on minor 0
audio0: cs4231a(eb2) at 1fff1200000 irq 13,7e3
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP
IP: routing cache hash table of 4096 buckets, 32Kbytes
TCP: Hash tables configured (established 32768 bind 16384)
NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
kjournald starting.  Commit interval 5 seconds
EXT3-fs: mounted filesystem with ordered data mode.
VFS: Mounted root (ext3 filesystem) readonly.
Adding Swap: 554888k swap-space (priority -1)
EXT3 FS 2.4-0.9.19, 19 August 2002 on ide0(3,1), internal journal

Attachment: signature.asc
Description: This is a digitally signed message part

Reply to: