[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

cannot logon on to sparc as only certain keys work - keys type strange characters - locked out


(Thanks to Ferris McCormick and Patrick McGlennon for help on earlier X
Server Problems posted by me earlier in week. It worked. Really

So after two months, I was finally able to load KDM. It worked beautifully
on my Ultra 10 sparc and I set about reconfiguring the desktop. One of the
first things I noticed was that the keyboard type strange characters in
Abiword and the console. This was strange as prior to getting X to work, all
my keys were fine (apart from the keyboard seeming to be in US mode.) I was
confident however of restting my keyboard to UK from within KDM but the
settings that I choose in keyboard did not seem to reset it to UK so I
decided to reboot in the hope that my keyboard layout problems would
disappear. BOY, what a mistake.

I am now left staring at a GNOME Desktop login screen where only some
alphabetic keys work and the ones that work type alternative characters such
as p=o, y=t, t=r, o = i etc.

I would have been able to get around this as I have mapped all the keys
which correspond to the login 'root' and my password but it doesn't allow
the administrator to log in from this screen so I have to use my own name
'kevin' but I cannot get the characters for 'v' or 'n' to appear so I am
pretty much locked out.

Can anyone help or can anyone tell me the command that I can type at the
lilo prompt to enter perhaps some sort of console that might allow me to log
in as 'root' and fix my keyboard problem.


Reply to: