[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Problems with XFree86 finding sunBWtwo framebuffer

  I'm trying to get an old Sun SLC working as an X terminal.  I've got a
working Debian-3.0r0 installed on an Ultra IIi/PCI based system and have
been using it to build a filesystem for the SLC to boot from.  It
currently boots and happily gets as far as running bash - the problem is
with getting it to run XFree86.

Currently /etc/X11/XF86Config-4 contains:

Section "Device"
        Identifier  "SLC Monochrome Frame Buffer"
        Driver      "sunbw2"
        VendorName  "Sun"
        BoardName   "Black and White Framebuffer"
        BusID       "sbus:/sbus@1,f8000000/bwtwo@1,fe000000"

Section "Monitor"
        Identifier	"Sun SLC Monitor"
        HorizSync	61-82
        VertRefresh	66-85

Section "Screen"
    Identifier  "Default Screen"
    Device	"SLC Monochrome Frame Buffer"
    Monitor	"Sun SLC Monitor"
       SubSection "Display"
               Depth		1
#		Modes		"1024x768" "800x600" "640x480"
    DefaultColorDepth   1

But when I start X it dies with:

"(EE) No devices detected"

Their appears to be no useful documentation on this with XFree86 itself
or on their website.  As far as I know the BusID parameters are right
but that's only what I've worked out from the source code.  I've tried
using /dev/fb/0 and the fbdev driver but it keeps on failing claiming ti
can't handle a colour depth of 1 and has unresolved symbols.
I was going to try and recompile XFree86 but I found the config so
confusing and the documentation so poor that I've no idea how to go
about doing so.  With the XFree86 source I've found what appears to be
source for Xsun but I've no idea how to go about compiling it.

Can anyone shed any light on this - I'm getting frustrated because
they're so near to working.

Sweet Dreams,
 - Martin

"Seasons change, things come to pass"

Reply to: