[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: kernel 2.5.68 and egcs64

On Sun, Apr 20, 2003 at 08:42:52AM +0200, Fabio Massimo Di Nitto wrote:
> Hi all,
> 	from this kernel version init/main.c implements a check about gcc
> version used to compile the kernel (line 63) and it fails with egcs64
> shipped with Debian.
> The only workaround I found on the fly and with basically no investigation
> was to purge egcs64 and create a symlink in /usr/bin for sparc64-linux-gcc
> to gcc-3.3 (gcc-3.2 will fail because of an unrecognized options).
> Im not sure if this is the proper fix so I would like someone more expert
> to take a look to it before reporting bugs to any package (if it is a
> bug).
> But if my feelings are correct probably gcc-3.3 should replace egcs64 and
> provide sparc64-linux-gcc.

For now I just removed that check from init/main.c.

For the long term, gcc-3.3 doesn't build working kernels for me. Maybe
one day it will, but when it does, it wont provide sparc64-linux-gcc, it
will provide just plain gcc, since the sparc64 kernel Makefiles already
check if gcc is capable of 64bit kernel builds.

I may try to get gcc-3.2 doing 64bit builds.

Debian     - http://www.debian.org/
Linux 1394 - http://www.linux1394.org/
Subversion - http://subversion.tigris.org/
Deqo       - http://www.deqo.com/

Reply to: