[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Woody on Sparccenter 2000

Hi all,

this mail aims at 
	1/ feedback on installing woody on a sparccenter 2000
	2/ question about compiling kernel for this machine

Installation of woody didn't caused me much trouble : the main is it can't
boot from CD.
Kernel loading ends with a 'data access exception' message. However, the
tftboot imagee is ok and everything went ok through the lan.

You will find below the configuration of the machine (2system boards)

Then :
Since default kernel doesn't support SMP, I tried to recompile the kernel with
SMP support.. Unfortunately, the kernel stops loading with a message such as
"watchdog reset" and drop me back to the openboot prompt. Surprinsignly, I got
the same message without SMP support on my own kernels. Debian default kernel
is the only I can boot with. the kernel coming from the package
kernel-image-2.2.20*sun4d*-smp gives the same error message.

I thought it mighht have been a problem similar to old lilos (on i386) and
tried to copy kernels in a separate partition at the beginning of the disk. No
more results.

Any clue ?

If the kernel is still in development and these problems are 'normal', I can
give some people an access to a machine running a console-server wich may help
to debug kernel on this type of machine.
But since I saw other people running linux on their sparccenter... I'd like to
do the same too :)

Many thanks

PROMLIB: Sun Boot Prom Version 3 Revision 2
Linux version 2.2.20 (root@auric) (gcc version 2.95.2 20000220 (Debian
GNU/Linux)) #1 Fri Nov 16 15:48:02 EST 2001
TYPE: SPARCcenter 2000
Ethernet address: 8:0:20:1b:d0:4b
Boot time fixup v1.6. 4/Mar/98 Jakub Jelinek (jj@ultra.linux.cz). Patching
kernel for srmmu[TI Viking/MXCC]/io-unit
[0]: v[f0000000,fd000000](d000000) p[00000000]
[1]: v[e1000000,efeb2000](eeb2000) p[0d000000]
Found CPU 0 <node=ffd8e578,mid=0>
Found CPU 1 <node=ffd8e8f4,mid=2>
Found 2 CPU prom device tree node(s).
Console: colour dummy device 80x25
Calibrating delay loop... 84.99 BogoMIPS
Memory: 449060k available (1340k kernel code, 6848k data, 168k init)
Dentry hash table entries: 65536 (order 7, 512k)
Buffer cache hash table entries: 262144 (order 8, 1024k)
Page cache hash table entries: 65536 (order 6, 256k)
POSIX conformance testing by UNIFIX
sbus0: Clock 20.0 MHz
dma0: ESC Revision 1 
dma1: ESC Revision 1 
sbus1: Clock 20.0 MHz
dma2: ESC Revision 1 
Linux NET4.0 for Linux 2.2
Based upon Swansea University Computer Society NET3.039
NET4: Unix domain sockets 1.0 for Linux NET4.0.
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP, IGMP
TCP: Hash tables configured (ehash 524288 bhash 65536)
Linux IP multicast router 0.06 plus PIM-SM
Starting kswapd v 1.5 
Console: switching to colour frame buffer device 128x54
fb0: cgsix at 8.10000000 TEC Rev 1 CPU 68020 Rev 6 [GX]
Sparc Zilog8530 serial driver version
tty00 at 0xfd02b004 (irq = 12) is a Zilog8530
tty01 at 0xfd02b000 (irq = 12) is a Zilog8530
tty02 at 0xfd02c004 (irq = 12) is a Zilog8530
tty03 at 0xfd02c000 (irq = 12) is a Zilog8530
tty04 at 0xfd02d004 (irq = 12) is a Zilog8530
tty05 at 0xfd02d000 (irq = 12) is a Zilog8530
tty06 at 0xfd02e004 (irq = 12) is a Zilog8530
tty07 at 0xfd02e000 (irq = 12) is a Zilog8530
Sun TYPE 4 keyboard detected without keyclick
QPTI: Total of 2 PTI Qlogic/ISP hosts found, 2 actually in use.
scsi0 : Sparc ESP236-FAST
scsi1 : Sparc ESP236-FAST
scsi2 : Sparc ESP236-FAST
scsi3 : PTI Qlogic,ISP SBUS SCSI irq 5,4d regs at fd032000 PROM node ffdad4c8
scsi4 : PTI Qlogic,ISP SBUS SCSI irq 5,4e regs at fd033000 PROM node ffdb3b30
scsi : 5 hosts.


Reply to: