[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: X on a sparc 10 - Creator 3D, Sony 21 - howto?

On Thu, 2002-08-01 at 10:09, Ben Collins wrote:
> On Thu, Aug 01, 2002 at 08:16:14AM -0400, Eduardo Mendes wrote:
> > Hello
> > 
> > Debian is now the sole OS on my sparc 10.  The installation process went fine 
> > despite a slow internet connection (thanks to all on the list again and 
> > again).
> > 
> > Although the installation process went through all the settings for X, the 
> > only thing that came out was a blank screen (I didn't see the mouse pointer 
> > at all so I assume that X settings are completely wrong).  I tried to find a 
> > xsetup, xconfigurator and etc. but the only thing that came out was  
> > xf86config (which didn't help at all!). Ok, how can I sucessfully configure X 
> > for a sparc 10 with Creator 3D and Sony monitor, model GDM 501PT?
> dpkg-reconfigure xserver-xfree86
> If you get a black screen, wait, and wait some more. It's possible that
> you are using swap space to start X, and it could take time under those
> circumstances.
This is interesting. I'm using Debian GNU/Linux on one Ultra 30. My
video card is creator 3D (according to the command "dmesg"). However,
until today, I couldn't make my Xserver start using the binary
/usr/X11R6/bin/X. But, I got xserver-xsun24 (3.3.6), extracted the
binary Xsun24, deleted the /usr/X11R6/bin/X and changed Xsun24 into
/usr/X11R6/bin/X. After that I gave the following commands:
chown root.root /usr/X11R6/bin/X
chmod 4755 /usr/X11R6/bin/X
startx... and now it works!!!
That is, I'd like to know: Why my system works with an antiquade binary?
I really don't know, but it works!
Is there a reason for this?

Thank's in advance!

Antonio Luiz Pacifico

Reply to: