[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Installation Questions

Hi, thanks for the explanation. Can I ask another 2 questions,

Is this the same for /target ??

I installed from floppies last night and it all worked (apart from the fact
it wouldn't do it from CD hence the floppies), however
	a) I couldn't make the hard disk bootable
	b) I couldn't make a boot disk (tried multiple times with multiple

I hopped into a shell (in RAM or on floppy I pressume)  while in the install
only to find that all my mount points (/, /usr, /var, /home, /boot) are all
in a directory called target, ie. /target/, /target/usr, /target/var etc.
Is this supposed to happen? or is this just because I was in the shell, ie
if I'd been able to boot normally, I'd have seen /, /usr, /home as per other
Linux installations.

Why wouldn't my hard disk have been bootable ?
During the partitioning stage I made one of the partitions bootable but I
can't remember which one hence it probably wasn't the /boot.
How many of the partitions need to be bootable, ie /boot or /boot + / or
/boot + / + /usr etc.
If it is just the /boot that needs to be bootable, should the following
config work ?

	sda1	20Mb		/boot	*(bootable partition)
	sda2	800Mb		/
	sda3	512Mb		<swap>
	sdb1	800Mb		/usr
	sdb2	500Mb		/var
	sdc1	400Mb		/home
(I've got 2 1.3Gb and one 400Mb drives & numbers are approximate)

Thanks in advance

  Damian Del Campo,  B.Eng (Comp Sys - Hons)
  Software Engineer,  SAGRN Project
  Phone  	08 8401 7037	(Flinders St)
  Fax      	08 8231 1385
  E-mail  	Damian.DelCampo@team.telstra.com

> -----Original Message-----
> From:	jbiddier@usra.edu [SMTP:jbiddier@usra.edu]
> Sent:	Monday, 24 September 2001 9:37 pm
> To:	Del Campo, Damian
> Cc:	'debian-sparc@lists.debian.org'
> Subject:	Re: Problems Installing Debian on a Sparc2
> "Del Campo, Damian" wrote:
> > 
> > Thanks to those who've helped.
> > 
> > I think there must be something wrong with my CD ROM, I can install from
> > floppies without problems. After the "partitioning" section, the
> "install
> > Linux" section allows for varoius media but when I choose CD ROM nothing
> > happens, ie the light doesn't even come on and you can't hear/feel the
> CD
> > spinning, however doing a probe-scsi from the PROM and during the SILO
> > initialisation, you can see the CD ROM detected.
> > Either way, I'll get it happening off the floppies and then try and
> figure
> > how to do it from the CDs. Or if there's some way of installing all the
> apps
> > from the install CDs once the actual system is set up, then I'll do
> that. I
> > can't be stuffed hand installing Gbs worth of software.
> > 
> > One more question, why is there a /boot mount ? Admittedly I've only
> ever
> > used RedHat before so maybe this is standard but I've never seen it.
> > 
> > Anyway, thanks people for the help.
> > 
> >   Damian Del Campo
> >   Software Engineer,  SAGRN Project
> >   E-mail        Damian.DelCampo@team.telstra.com
> > 
> Well, for some reason my un-subscribe did not work. I am still on the
> mailing list. I'll take it as a omen for now and un-subscribe later.
> The /boot directory holds the kernel (vmlinux-<version>) and system map
> (System.map-<version>. It does exist under RedHat, but it is not
> requested to be it's own partition during the installation process.
> RedHat will put "/boot" under the "/"(root) partition unless you create
> the "/boot" partition. Oddly, Debian has the symbolic link vmlinux in
> "/"(root) and not in "/boot" like RedHat and other Linux distributions.
> It makes no difference for this is really all sorted out in the
> silo.conf (or lilo.conf for PCs).  
> I will attest to some of the responses concerning the use of floppies;
> many SS2's do have crappie floppy drives and the installation can be
> fustrating - but it can be done (I have done it). You may want to obtain
> another Sun compatible internal (or external) CDROM (some of the old
> SCSI Toshiba CDROMs do well.).
> --J

Reply to: