[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

problem with rsync

I'm having problems with rsync running on a sparc using woody, if I use
rsync from woody it doesn't work, but if I use the one from potato it works

I have tested the same configuration on i386 and it works ok, so maybe this
problem is related to the kernel or something, here is my config:

timeout = 1800
dont compress = *.zip *.z *.bz2 *.rar *.gz *.tgz *.deb *.rpm
uid = nobody
gid = nogroup
max connections = 10

path = /usr/debian-tmp/images
comment = Temp cd image building dir
auth users = manty
read only = true
list = false
secrets file = /etc/rsyncd.seci

path = /home/ftp/unofficial-debian-cds
comment = Unofficial Debian woody cd images export area
read only = true

The machine runs kernel 2.2.20pre6 from the cvs on vger, as 2.4 doesn't want
to run on it. Machine is a 4 slot Sun Enterprise 3000 with two ultrasparc

I'm getting this error when I try to access the tmpcd module, not the other
one, and it outputs the error before even prompting for the password or
anything. This is the error:

@ERROR: max connections (10) reached - try again later

The maximum connections is in fact 10, but there is nobody connected at all,
I have tried increasing the number but I only got the increased number on
the error.

Machine works ok and I have not seen any other weird behaviour besides on
the ftp servers, where if I download big files (cd images) using an ftp
server different from the wu-ftpd data is corrupted, and I have tried almost
all the ftp servers on testing.

Well, I'd like to know if anybody with a similar machine/similar kernel can
give this a try or something.

Thank you very much on advance.

Manty/BestiaTester -> http://manty.net

Reply to: