[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

E450 and "link down" problems with happy meal

I just installed Debian 2.2r3 Potato on a 4cpu E450, but cannot get
any of the two ethernet interfaces to work. Both just repeats these
messages continuously:

eth0: Link down, cable problem?
eth0: Auto-Negotiation unsuccessful, trying force link mode
eth0: Link down, cable problem?
eth0: Auto-Negotiation unsuccessful, trying force link mode
eth0: Link down, cable problem?

The link is up and negotiated to 100baseTX-FD according to the switch
in the other end. I've tried replacing the connection to the switch
with a crossover cable to a PC, getting the same results: The PC
claims to have negotiated 100baseTX-FD, but the Sparc disagrees. I
also tried forcing the switch port to all combinations og 10/100 and
FD/HD without any effect.

Both interfaces were working using Solaris 2.6 before I started
installing Linux.

I notice the HAPPY MEAL ethernet controller doesn't generate any
interrupts (the box is full of scsi controllers, but has only one disk
at the moment):

cat /proc/interrupts 
  0:     682248 + timer
  3:      16358   sym53c8xx, sym53c8xx
  4:         60   su(mouse), sym53c8xx, sym53c8xx, HAPPY MEAL (PCI)
  6:         60   sym53c8xx, sym53c8xx
  9:          0   su(kbd)
 11:         18   floppy
 12:      60032   serial(sab82532)
 15:          0   power

I don't know if this is as it's supposed to be on a sparc. Please
excuse my total lack of knowledge of the platform. Up until now, I've
just been happy running Solaris without ever bother learning anything
about the system below. Time to change that, I guess :-)

I though maybe it could be just a bad default transceiver choice, but
how the heck do I change that? mii-tool and ifconfig just agree that 
the operation isn't supported for their respective ioctls:

 ifconfig eth0 media 100baseTX
 SIOCSIFMAP: Operation not supported

 /usr/src/mii-tool/mii-tool eth0
 SIOCGMIIPHY on 'eth0' failed: Operation not supported

So, I found an external transceiver and tried with that: Still no go. 

Now I'm starting to feel a bit stupid (and realise that i'ts probably
not just a feeling...), but I would really appreciate it if someone
would care to enlighten me. This cannot be that hard, so I'm pretty
sure I'm overlooking some simple solution.

(I would be grateful if any answers were CCed me. I don't think my
subscribtion has gone through yet. But I will try to follow the thread
on the archive pages)


Reply to: