[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: RAID again

> Ok, some of the ioctl translations aren't done for raid it seems. I
> suggest trying a 2.4.x kernel (especially on sparc64). I could check
> into the translations for you if they don't work on 2.4.x. If you want
> to check yourself, look at arch/sparc64/kernel/ioctl32.c

I'm afraid trying 2.4 was even worst, ok, at first I tried to compile 2.4 to
get a simple kernel, but I just couldn't get it to compile under potato on
the sparc, this is the error I got when making it...

/bin/sh ./check_asm.sh -data thread tmp.i check_asm_data.c
sparc64-linux-gcc -D__KERNEL__ -I/usr/src/kernel-source-2.4.5/include -m64
-mcmodel=medlow -ffixed-g4 -S -o check_asm_data.s check_asm_data.c
In file included from /usr/src/kernel-source-2.4.5/include/linux/wait.h:13,
                 from /usr/src/kernel-source-2.4.5/include/linux/fs.h:12,
                 from /usr/src/kernel-source-2.4.5/include/linux/sched.h:9,
                 from check_asm_data.c:4:
/usr/src/kernel-source-2.4.5/include/linux/kernel.h:132: size of array f'
is too large

Well, so I said I'm gonna install one of our binary kernels, and I chose the
2.4.5 kernel for the usparc with smp support, I rebooted and  2.4.5 came up
smoothly, untill I saw the line that showed that it had mounted the root fs
and then it died, this are the last lines I can see on the serial console:

VFS: Mounted root (ext2 filesystem) readonly.

It continues ouputting that Ica stuff on and on :-(

I cannot do any more tests till tomorrow, as I cannot access the PROM, I
have access to the serial console, so I tried sending a Break several times
from minicom, but doesn't work.

Do you thing I should still try to test 2.4 again on this machine?
Doesn't seem I could be getting much farther with it.

Manty/BestiaTester -> http://manty.net

Reply to: