[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problems when "cloning" an hard-disk

try dd if=/dev/sda3 of=/dev/sdb3 bs=8000k

or better yet:
# man dd
and use your original disk as the "if" infile and the
"to be cloned disk" as the "of" outfile.

You will want to select the "whole disk" partition or slice
for the copy.


Sabino Maggi wrote:

> Hello all!
> I have a Sparc IPX with with two hard-disks, an external (slow!) 2 GB hd
> for the OS (Debian GNU/Linux potato) and an internal hd mounted as
> /home.
> I want to "clone" my existing system on a new disk. What I have done is:
> 1. I have substituted the internal disk with the new one;
> 2. I have booted the present system, partitioning and formatting the new
> hd (/dev/sdb).
> I have not forgot to have a "whole disk" partition (/dev/sdb3) and I
> have created 3 other partitions on this disk for /, /home and swap.
> 3. Then I have mounted /dev/sdb1 as /mnt/new-disk/, copying the old fs
> on the new disk:
> 'cp -ax / /mnt/new-disk'. I have also checked everything and the copy
> seems fine.
> 4. I have finally edited /mnt/new-disk/etc/fstab to reflect the new
> hard-disk partitioning scheme.
> 5. (I have also copied the /home partition on the new system, but I
> think this has nothing to do with what I am describing here.)
> What I have done is basically the same that I did on my pc at home
> without any problems. The main difference is that here I have not run
> 'silo' after changing fstab.
> However, when I try to boot off the new hd (physically removing also the
> connection to the external disk), I get this error message:
> "Boot device: /sbus/esp@0,800000/sd@1,0 File and args:
> The file just loaded does not appear to be executable.
> Type b (boot)..."
> It goes without saying that probe-scsi correctly recognizes the hd and
> that the scsi id is right. I have also tried to enable/disable bus
> termination on the hd with no result.
> What am I doing wrong?
> Thanks
> Sabino
> --
>       +---------------------------------------------------+
>       | Windows NT has detected that there were no errors |
>       | for the past 10 minutes. The system will now try  |
>       | to restart or crash. Click the OK button to       |
>       | continue.                                         |
>       |                       < Ok >                      |
>       +---------------------------------------------------+
> -----------------------------------------------------------------
> Sabino Maggi                     !  tel: (+39) 011-3919-449 *NEW*
> IEN "G. Ferraris"                !  fax: (+39) 011-3463-84
> Strada delle Cacce, 91           !  e-mail: maggi@ien.it
> I-10135 Torino, Italy            !  http:   www.ien.it/~maggi
> -----------------------------------------------------------------
> --
> To UNSUBSCRIBE, email to debian-sparc-request@lists.debian.org
> with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Tad Bilby
Rave Computer Assoc.
Technical Support
800-966-7283 x224

Reply to: